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Executive Summary 
 
The Joint Interoperability Test Command conducted a functional test of the web-based 
version of the Standard Labor Data Collection and Distribution Application (SLDCADA) 
version 21.2 for the Naval Sea Logistic Center (NAVSEA) from 29 May through 1 June 
2001. 
 
The functional test was conducted at the NAVSEA Detachment Atlantic facility in 
Yorktown, VA.  
 
The SLDCADA is a timekeeping system that allows for centralized or distributed input, 
providing the capability to track civilian, military, as well as contractor labor hours 
against job order numbers for financial purposes, and hours against type hour codes for 
pay purposes. 
 
Only the functional capabilities were considered during test preparation.  This effort 
identified 263 functional requirements for the SLDCADA application.  Eight Software 
Test Descriptions were prepared to verify and validate 100 percent of the identified 
requirements for SLDCADA.  However, 18.3 percent of the total requirements were not 
tested because of time limitations.  Those requirements not tested were ranked as 
priority 4 and 5.  There would have been no operational impact if these requirements 
had been tested and failed.  In addition, 3.2 percent of the requirements were no longer 
applicable due to system changes. 
  
The overall tested functional performance of the system was considered good. Of the 
remaining 78.5 percent of the total requirements, 91.79 percent were successfully 
demonstrated during this test. 
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Section 1.  Scope 
 
 
1.1  Identification 
 
The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval 
Sea Logistic Center (NAVSEA) developed Time and Attendance System that has 
recently been chosen as the Department of Navy standard.  
 
The SLDCADA is a timekeeping system that allows for centralized or distributed input, 
providing the capability to track civilian, military and contractor labor hours against job 
order numbers for financial purposes, and hours against type hour codes for pay 
purposes.  
 
The purpose of this document is to annotate the test results of the Joint Interoperability 
Test Command (JITC) Functional Qualification Test (FQT) of SLDCADA.   
 
1.2 Background 
 
The Department of the Navy chose SLDCADA as the new Time and Attendance 
application to be used at nearly all Navy activities. NAVSEA requested that JITC 
perform a Functional Qualification Test (FQT) on SLDCADA, a web-based Oracle 
system, before deploying it Navy wide. 
 
JITC was responsible for the formal FQT, which validated the integrity of the 
application’s performance by verifying documented requirements.   

 
1.3 Application Overview 
 
SLDCADA has many features to benefit the Navy’s Time and Attendance capabilities.  
These features include a leave availability check, prior pay adjustments, exception 
reporting, and the ability to query Defense Civilian Payroll System (DCPS) files (Master 
Employee Record & Biweekly Master Employee Record) for easy access to employee 
information by authorized users.  
 
The SLDCADA provides a single Time and Attendance screen for input, correction, 
certification, prior pays, and review, which ultimately reduces the training effort and 
makes user input easy.  All reports are on-line, resulting in a reduction of hard-copy 
reports.   
 
Interfaces are in place with the DCPS, the Department of Defense standard financial 
systems (Defense Information Financial Management System, Standard Accounting 
and Reporting System-Field Level and Standard Accounting and Reporting System-
Headquarters), as well as other various local financial systems. 
 
The SLDCADA is designed to be parameter driven; therefore it may be tailored to meet individual site 
requirements. By being able to customize the SLDCADA application, the site is provided with maximum 
flexibility, thus making it possible to satisfy a site's particular needs. 
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Section 2.  Documentation Overview 
 
 

2.1 Test Preparation  
 
JITC established a structured, standardized testing process for the SLDCADA FQT.  
The pre-test events are the foundation for the follow-on activities.  
 
JITC identified 263 functional requirements for the SLDCADA web-based application.  
The requirements were derived from the documentation obtained from the SLDCADA 
Program Management Office (PMO).  In order to assure that full coverage of the 
requirements have been accomplished, JITC mapped each requirement to a step in the 
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Software Test Description (STD) documents.  These functional requirements were 
tested to validate the functionality of the application.  
 
There were eight STDs written for the web-based version of SLDCADA.  The STDs are 
included in this test plan and can be found in Appendix C.  The STDs identified for 
SLDCADA are summarized in paragraph 4.2.  These scenarios were specific in 
assigning each operator input, expected results, requirement cross reference, 
dependencies on other test items or products, and any other critical dependencies 
projected to be a consideration during test.  The SLDCADA functional test was 
conducted 29 May through 1 June, 2001. 
 
2.2 Reference Documents 
 

a)  SLDCADA Functional Assessment Proposal, dated 31 January 2001. 
 

b)  SLDCADA Software User’s Manual (Web), dated 8 May 2001. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Section 3.  Test Environment 
 
 
3.1   Hardware Considerations 
 
The following describes the hardware items that will be needed to conduct SLDCADA 
testing: 
 

Sun Sparc Database Server 
486/33 or higher processor 
3.5-inch high-density floppy drive  
 

Windows NT Workstation 
486/33 or higher processor 
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16 MB Memory 
3.5-inch high-density floppy drive 

 
3.2  Software Considerations  
 
The following table describes the software items that will be needed to conduct 
SLDCADA testing: 
 

Netscape Version 4.5 or later 
ORACLE Version 8.1.6 
Solaris Version 2.6  
SLDCADA Version 21.0 executable code 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

Section 4.  Test Details 
 
 
4.1 Test Objectives   
 
The JITC testing approach is a modified FQT that will insure that all test objectives are 
satisfied.   

The FQT dealt primarily with the assessment of the systems’ functional requirements.  
The functional testing approach was a comprehensive effort designed to verify and 
validate all of the system’s functional requirements. It was conducted in a formal nature, 
with JITC and Subject Matter Experts (SME) working side by side. JITC, in many cases, 
initiated most of the button actions, as well as annotated the results or problems and 
made necessary changes to the STDs previously prepared by JITC.  SMEs were on 
hand to act in a consulting capacity, utilizing their SLDCADA functional expertise as 
required. This procedure was done to facilitate the aggressive turn-around time for 
analysis and results.  During the actual testing period, problems encountered, 
preliminary analysis of problems, and test schedule progress were made by JITC.   
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4.2  Test Summary 
 
Each STD prepared for SLDCADA was designed with an individual objective and subset 
of requirements to be validated.  During the test, the JITC test team annotated these 
STDs, with test results, to fully document the testing progress of SLDCADA. 
 
Only the functional capabilities were considered during test preparation.  This effort 
identified 263 functional requirements for the SLDCADA application.  Eight Software 
Test Descriptions (STDs) were prepared to verify and validate 100 percent of the 
identified requirements for SLDCADA.  The total percent of requirements not tested 
equals 21.5 percent, while 78.5 percent of the total requirements were tested.  The 
requirements are attached to the back of each STD.  The STDs are summarized below 
and detailed in Appendix C. 

         75.4%      4.3%        7.7%         8.7%          1%          1.4%          .5%            1% 
 

Graph 1 – SLDCADA Requirements to STD 
4.2.1 CIVILIAN SA/AL:  The Civilian SA/AL STD verifies that the user is able to access all 

employees and has Administrator privileges.   This STD validates that SLDCADA provides the user with 
the ability to input, correct, certify, and review every employee’s time and attendance records, through an 
automated web-based application.   
 

Disposition of Requirements: One hundred and fifty six of the testable 
requirements were allocated to this description.  This represented 75.4 
percent of the overall testable requirements. 

 
Risk Analysis: Eleven of the 156 requirements allocated to this STD resulted in a trouble report.  
There were seven trouble reports written for this STD.  The requirements were assigned to the 
following Trouble Reports: SLDCADA-0001, priority 4; SLDCADA-0002, priority 3; SLDCADA-
0003, priority 3; SLDCADA -0004, priority 3; SLDCADA-0005, priority 2; SLDCADA-0006, priority 
1; and SLDCADA-0007, priority 3. 
 
Impact Statement: Trouble Reports SLDCADA-0005 and SLDCADA-0006 
resulted in operational impacts.  JITC was unable to verify that the clocks worked 
as intended because the screen would freeze upon selection.  The requirements 
affected were ranked a priority two by the SME.  In addition, JITC was unable to 

0

20

40

60

80

100

120

140

160

STD- 1  156

STD- 2  9

STD- 3  16

STD- 4  18

STD- 5   2

STD- 6   3

STD- 7   2

STD- 8   1



 

6  

certify employees work hours.  This is a primary function of SLDCADA and was 
ranked a priority one by the SME.   
 
4.2.2 MILITARY SE/SE INQUIRY ONLY:  The Military SE/SE Inquiry Only STD 

verifies that the user can obtain his information with read-only access. The user will not 
be allowed to update any information or look at any other employee’s information.   

 
Disposition of Requirements: Nine of the testable requirements were 
allocated to this description.  This represented 4.3 percent of the overall 
testable requirements. 

 
Risk Analysis: All requirements allocated to this STD were successfully demonstrated.   
 
Impact Statement: There are no operational impacts associated with this STD. 

 
4.2.3 MILITARY SE/SE UPDATE:  The Military SE/SE Update STD verifies that 

the user can obtain only his information.  The STD also verifies that the user can update 
and review any information in his record.  
 

Disposition of Requirements: Sixteen of the testable requirements were 
allocated to this description.  This represented 7.7 percent of the overall 
testable requirements. 

 
Risk Analysis: One of the 16 requirements allocated to this STD resulted in a trouble report.  The 
requirement was assigned to Trouble Report SLDCADA-0007, priority 4. 
 
Impact Statement: There are no operational impacts associated with this STD. 

 
 4.2.4 NON-EMPLOYEE SU/SG:  The Non-Employee SU/SG STD verifies that 
the user is able to access the supervisor assigned group and has Supervisor privileges.  
This STD validates that SLDCADA provides the Supervisor the ability to input, correct, 
certify, and review all of the Supervisor’s assigned employee’s time and attendance 
records through an automated web based application.    
 

Disposition of Requirements: Eighteen of the testable requirements were 
allocated to this description.  This represented 8.7 percent of the overall 
testable requirements. 

 
Risk Analysis: One of the 18 requirements allocated to this STD resulted in a trouble report.  The 
requirement was assigned to Trouble Report SLDCADA-0007, priority 4. 
 
Impact Statement: There are no operational impacts associated with this STD. 
 
4.2.5 CIVILIAN TK/CC:  The Civilian TK/CC STD verifies that the user is able to 

access the employees in the user’s shop and has Time-Keeper privileges.  This STD 
validates that SLDCADA provides the user with the ability to input, correct, certify, and 
review all of the user’s shop employees’ time and attendance records through an 
automated web based application.    
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Disposition of Requirements: Two of the testable requirements were 
allocated to this description.  This represented 1.0 percent of the overall 
testable requirements. 

 
Risk Analysis: The two requirements allocated to this STD were successfully demonstrated. 
However, Trouble Report SLDCADA-0008 was created in reference to this STD.   
 
Impact Statement: There are no operational impacts associated with this STD. 

 
 4.2.6 CIVILIAN TK/XC:  The Civilian TK/XC STD verifies that the user is able to 
access all of the employees in the user’s shop and all employees in shops that are 
cross-referenced to the user’s shop.  The STD also verifies that the user has Time-
Keeper privileges.  This STD also validates that SLDCADA provides the user with the 
ability to input, correct, certify, and review all of the user’s shop employees’ time and 
attendance records through an automated web-based application.    
 

Disposition of Requirements: Three of the testable requirements were 
allocated to this description. This represented 1.4 percent of the overall 
testable requirements. 

 
Risk Analysis: Two of the three requirements allocated to this STD resulted in  a trouble report.   
The requirements were assigned to Trouble Report SLDCADA-0010, priority 3.  
 
Impact Statement: There are no operational impacts associated with this STD. 
 
4.2.7 CIVILIAN SES SA/AL:  The Civilian SES SA/AL STD verifies that the user 

is able to access all employees and has Administrator privileges.  The STD also verifies 
that SES specific codes are operational. This STD validates that SLDCADA provides 
the user with the ability to input, correct, certify, and review all employees’ time and 
attendance records through an automated web-based application.    

 
Disposition of Requirements: Two of the testable requirements were 
allocated to this description. This represented 1.0 percent of the overall 
testable requirements. 

 
Risk Analysis: One of the two requirements allocated to this STD resulted in a trouble report.   
The requirements were assigned to Trouble Report SLDCADA-0011, priority 3.  Trouble Report 
SLDCADA-0009 was created for this STD, 
however, this Trouble Report does not affect any specific requirements. 
 
Impact Statement: There are no operational impacts associated with this STD. 
 
4.2.8.  CIVILIAN INTERMITTENT SA/AL:  The Civilian Intermittent SA/AL STD 

verifies that the user is able to access all employees and has Administrator privileges.  
The STD also verifies that Intermittent specific codes are operational.  This STD 
validates that SLDCADA provides the user with the ability to input, correct, certify, and  
review all employees’ time and attendance records through an automated web-based 
application.    
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Disposition of Requirements: One of the testable requirements was 
allocated to this description.  This represented .50 percent of the overall 
testable requirements. 

 
Risk Analysis: The requirement resulted in Trouble Report SLDCADA 0012, priority 3.  
 
Impact Statement: There are no operational impacts associated with this STD. 

 
 
 
 
4.3  Data Analysis 
 
The majority of the data collected was formatted and placed into a traceability database.  
The information was consolidated and an associated disposition regarding its status 
was assigned. The detailed requirement disposition listing is included as an appendix to 
each STD.  
 
The requirements were sorted by percentages for those tested, failed, not tested, and 
no longer applicable, and are represented in the test depth and breadth SW metric 
shown in Graph 2. 
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                100%                     78.5%                      91.79%                   8.21%                     18.3%                      3.2% 
 

Graph – 2 Requirement Dispositions 
 

4.4   Test Reporting 
 

Daily Emerging Results Reports (ERRs) were submitted to and discussed with the 
SLDCADA PM, highlighting any issues that needed to be addressed to the SLDCADA 
Program Manager (PM). 
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This test report cross-references the requirements with any associated trouble report.  
There were two trouble reports that have an associated operational impact. This report 
also presents the results in graphs and tables, for charting purposes. 
 
The appendices of this report include the completed STDs annotated with resulting 
information, the actual trouble reports, the requirements as they were allocated to each 
STD, and other administrative appendices to support the results.   
 
The test report will be provided, in original form, to the PM of SLDCADA. 
4.5 Software Trouble Reports   
 
Fourteen Trouble Reports were written against this version of SLDCADA.   Below is a table summary of 
the Trouble Reports. The individual trouble reports can be found in Appendix D.  
  
Number Title P O Requirement 
SLDCADA 0001 Help>Topics 4 N 35, 258 
SLDCADA 0002 EHz  Codes  3 N 95 
SLDCADA 0003 ND/EHz Codes 3 N 84 
SLDCADA 0004 Work Schedule 3 N 109 
SLDCADA 0005 Clocks 1/2 2 Y 107, 108, 110, 111 

SLDCADA 0006 Certify Only 1 Y 121 
SLDCADA 0007 Reference Icon 4 N 37, 178, 221 
SLDCADA 0008 RG Default N/A N No requirements associated 

with this TR. 
SLDCADA 0009 Firefighter ND Code N/A N No requirements associated 

with this TR. 
SLDCADA 0010 Firefighter LU/LT Code 3 N 92, 93 
SLDCADA 0011 SES B* Code 3 N 79 
SLDCADA 0012 Intermittent OS, ON, OU Codes 3 N 86 
SLDCADA 0013 Requirements Not Tested 4 N See TR for Listing 
SLDCADA 0014 Requirements Not Applicable 4 N See TR for Listing 

 
Table 1- Trouble Reports.
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Section 5. Points of Contact 
 

5.1 Task Management and Execution: The JITC POC for the technical conduct, management, and 
contractor performance of this task is: 

Luanne Overstreet 
ATTN:  Messaging and Information Systems Division 
4481 Indian Head Highway 
Indian Head, MD 20640 

                    DSN: 354-2695, COM: (301) 744-2695 
 
 
5.2 Funding: Initial and any follow-on funding to support this task should be forwarded as a Military 
Interdepartmental Purchase Request (MIPR) to  

 
Ms. Dina Martinez 
ATTN:  Financial Management Office (JTAF) 
Building #57305 
Fort Huachuca, Arizona, 85613 

          DSN:  879-3663, COM:  (520) 538-3663 
 

5.3 Customer Satisfaction: Any feedback concerning JITC’s performance, whether positive or negative, 
on this task should be made through the following POC: 

Mr. Michael P. Mangan, Division Chief 
ATTN:  Messaging and Information Systems Division 
101 Strauss Avenue, Bldg. 900 
Indian Head, MD 20640-5035 
DSN: 354-2604, COM: (301) 744-2604, FAX: (301) 744-2666 
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Appendix A 
Points of Contact 
 

Name Affiliation DSN/ Commercial 

SLDCADA PMO   

Priscilla Tillery Naval Sea Logistic 
Center 

(301) 744-6125 

   

SLDCADA Technical 
Support 

  

Natasha Mungal Naval Sea Logistic 
Center 

(757) 887-7824 

Tim Sledge  Naval Sea Logistic Center (757) 887-4441 
Beth Abbot Naval Sea Logistic Center (757) 887-8145 
   

JITC Test Team   

Luanne Overstreet JITC (301) 744-2695 
DSN 354 

Chrissy D. McMannes TRW (301) 744-2689 
DSN 354 
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Appendix B 
 

Acronyms  
 

DCPS Defense Civilian Payroll System 
  
FQT Functional Qualification Test 
  
JITC Joint Interoperability Test Command 
  
NAVSEA Naval Sea Logistic Center 
  
PMO  Program Management Office 
  
SLDCADA Standard Labor Data Collection and Distribution Application 
SME Subject Matter Expert 
STD Software Test Description 
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APPENDIX C 
 

Software Test Descriptions 
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APPENDIX D 
 

Trouble Reports 
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TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0001 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA Priority 4 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Help>Topics 

 Details Help topics could be accessed on the first try.  However, the second attempt resulted in an error message stating that 
  the page could not be found. This only happened in the Internet Explorer.  Netscape worked properly. 

Requirements 35, 258 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0002 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title EHz Codes 

 Details The EHz Code D* was supposed to work with certain type hour codes.  Each type hour code was tested with the  
 D* EHz code using employee Tweety Bird.  None of the type hour codes worked with the EHz Code D*. 

Requirements 95 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0003 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title ND/EHz Codes 

 Details The night differential codes were not valid with the EHz codes listed in the Time and Attendance screen.  The codes 
  tested were supposed to be valid codes to use with the night differential codes. 

Requirements 84 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0004 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Work Schedule 

 Details When selecting Work Schedule in any of the Time and Attendance, Correct and Certify and Certify Only windows, 
  the screen locks up.  Therefore, JITC could not test that they worked.  The developers stated that they believed  
 this to be a Java Script error.  

Requirements 109 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0005 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 2 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Clocks 1/2 

 Details When selecting the Clocks 1 or Clocks 2 tabs in any of the Time and Attendance, Correct and Certify and Certify  
 Only windows, the screen locks up.  Therefore, JITC could not test that they worked.  The developers stated that  
 they believed this to be a Java Script error.  
  
 Operational Impact:  JITC was unable to verify that the clocks worked as intended because the screen would freeze  
 upon selection.  The requirements affected were ranked a priority two by the SME.  

Requirements 107, 108, 110, 111 
 



 

C-1 

 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0006 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 1 
 OP Impact: Y N N/A 

 PLATFORM  HP SO LARIS NT 

 Title Certify Only 

 Details When in the Certify Only window, JITC was unable to Certify Week 1, Week 2 or Both for the Tweety Bird  
 employee.  In addition, JITC could not Uncertify Week 1, Week 2 or Both for the Rusty Wallace employee.  
  
 Operational Impact:  JITC was unable to certify employees work hours.  This is a primary function of SLDCADA  
 and was ranked a priority one by the SME.  

Requirements 121 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0007 
 TEST:  FQT 1 Test Case ID: STD 1-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 4 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Reference Icon 

 Details In the Military>Employee>Field screen the reference was not displaying for all of the reference icons that were  
 available.  

Requirements 37, 178, 221 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0008 
 TEST:  FQT 1 Test Case ID: STD 5-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 0 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title RG Default 

 Details The ungraded employee TYHR code defaulted to RG, a graded TYHR.  It should only default to an ungraded  
 TYHR (RF, RS, RT).  

Requirements No requirements associated with this Trouble Report. 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0009 
 TEST:  FQT 1 Test Case ID: STD 6-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 0 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Firefighter ND Code 

 Details The night differential code (ND) should not be able to be used with either firefighter or SES employee types.   
 Ultimately it did not allow for ND to be used, however, instead of receiving the error message as would normally  
 happen in SLDCADA, the other information entered was saved, but the ND code was deleted. 

Requirements No requirements associated with this Trouble Report. 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0010 
 TEST:  FQT 1 Test Case ID: STD 6-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Firefighter LU/LT Code 

 Details The firefighter injury date establishment code LU and the firefighter code LT that must be used with LU does not  
 work.  An error message is displayed stating that the user must establish an injury date.  

Requirements 92, 93 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0011 
 TEST:  FQT 1 Test Case ID: STD 7-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title SES B* Code 

 Details The SES EHz B* Code should not be able to be used for an SES employee type. Ultimately it did not allow for the  
 B* code to be used, however, instead of receiving the error message as would normally happen in SLDCADA, the  
 other information entered was saved, but the B* code was deleted. 

Requirements 79 
 



 

C-1 

 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0012 
 TEST:  FQT 1 Test Case ID: STD 8-CIVILIAN 
 TEST SITE:  Yorktown, VA  Priority 3 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Intermittent OS, ON, OU Codes 

 Details The TYHR Codes OS, ON and OU should not be allowed to work with an intermittent employee, but the TYHR  
 Code does save.  

Requirements 86 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0013 
 TEST:  FQT 1 Test Case ID: N/A 
 TEST SITE:  Yorktown, VA  Priority 4 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Requirements Not Tested 

 Details Some requirements were not test due to time constraints and access rights.  There would have been no operational  
 impact if these requirements had been tested and failed. 

Requirements 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 19, 40, 41, 43, 90, 91, 156, 157, 158, 159, 160, 161, 162, 163, 164, 165,  
 166, 167, 168, 169, 170, 231, 232, 233, 234, 235, 236, 237, 238, 239, 240, 241, 242, 243, 244, 245, 246 
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 TROUBLE REPORT 
 Prepared by: JITC Form #: SLDCADA-0014 
 TEST:  FQT 1 Test Case ID: N/A 
 TEST SITE:  Yorktown, VA  Priority 4 
 OP Impact: Y N N/A 

 PLATFORM  HP SOLARIS NT 

 Title Requirements Not Applicable 

 Details Some requirements were no longer applicable due to system changes. 

Requirements 78, 138, 139, 195, 197, 198, 256, 257 
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1.   Details of Test Case: STD 1-Civilian SA/AL 
 
 
1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea 

Logistic Center (NAVSEA) developed Time and Attendance System that has recently been chosen as the 
Department of Navy standard.  

 
The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the 
capability to track civilian, military, as well as contractor labor hours against job order numbers for financial 
purposes, and hours against type hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be 

logged in using the menu code SLDCADA Administrator and have access rights to All.   
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STD 1- Civilian SA/AL 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed. Successful Launch (1) 

2 Select Yes.  The Login Screen is displayed.   
3 Select Cancel. The Web Login Screen closes. Successful Cancel (14) 
4 Access the SLDCADA Web Login 

Screen. 
The Web Login Screen appears.   

5 Type the following: 
User ID: jgordan 
Password: stan 
Then select Login. 

The Login Error Message appears. Successful Invalid Login 
(15)  

6 Type the following: 
User ID:  jgordan 
Password: training_2 
Then select Login. 

The Login Error Message appears a second 
time. 

Successful Login Error 
(16) 

7 Select OK and type in the following: 
User ID:  jgordan 
Password: training_1 
Then select Login. 

The SLDCADA News screen appears. 
 

Successful User ID (13) 

8 Select the Help>Help Topics from the 
SLDCADA Main Menu, then close the 
screen. 

The Help menu is displayed and closed. 
 

Successful 
 
Failed TR 
#0001  
(For Req. 35 
and 258) 

Help (35, 258) 
Tool Bar (27)  
 

9 Select the Help>About from the 
SLDCADA Main Menu, then close the 
screen. 

The About SLDCADA Screen appears and 
closes. 

Successful About 
SLDCADA 
(24)  
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Event # Action Expected Results  Observations  Requirements  
10 Select the Tools>User Login Information 

from the SLDCADA Main Menu, then 
close the screen. 

The Current screen is displayed showing the 
current user logged into SLDCADA, then 
the screen closes. 

Successful Current User 
(33) User 
Information 
(259) Current 
User Report 
(260)  

11 Select the Tools>Current Week 
Information from the SLDCADA Main 
Menu, then close the screen. 

The Current Week Ending Date Information 
screen appears showing the weekend date, 
then the screen closes. 

Successful Current Week 
(34) Week 
Ending 
Information 
(261) Current 
Week Ending 
(262) 

12 Verify that the SLDCADA Status Bar is 
displayed at the bottom of the screen. 

The Status Bar is displayed on the screen. Successful Status Bar (26) 

13 Select Tools>System News from the 
SLDCADA Main Menu. 

The System News Screen appears.   

14 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Window appears. 
 
 

Successful Menu Bar (25) 
Time and 
Attendance 
(Default) (69) 

15 Select the Cancel button. The SLDCADA System News Screen 
appears. 

Successful Employee 
Name (Cancel) 
(52) 

16 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Screen appears. 
 
Note: Searches can be performed using the 
Employee Name, SSN, Shop or Supervisor 
Assignment. 

Successful Time and 
Attendance 
(Search) (70) 

17 Select the desired week ending date: 4-1-
00. 

The week ending date appears in the dialog 
box. 
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Event # Action Expected Results  Observations  Requirements  
18 Verify that the Shop is highlighted in the 

Search Criteria box, then enter the shop 
(ALL) into the Search Criteria Value box, 
then select Search. 

All shop labor hours are displayed in the 
Time and Attendance Data Screen. 
 
Note :  A shop will default to the only shop 
available if it is the only one assigned. 

Successful Shop (Search 
Criteria, 
Default, 
Search) (53, 
54, 55, 56) 

19 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Screen appears.   

20 Select the desired week ending date: 4-1-
00. 

The week ending date appears in the dialog 
box. 

  

21 Verify that the SSN is highlighted in the 
Search Criteria box, select the employee’s 
SSN (125309625) from the Search 
Criteria Value pull down menu, then 
select Search. 

The employees, with that SSN, labor hours 
are displayed in the Time and Attendance 
Data Screen. 

Successful SSN (Search 
Criteria, 
Search) (57, 
58, 59) 

22 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Screen appears.   

23 Select the desired week ending date: 4-1-
00. 

The week ending date appears in the dialog 
box. 

  

24 Verify that the Supervisor Assignment is 
highlighted in the Search Criteria box, 
enter All in the Search Criteria Value box, 
then select Search. 

All employees, with that supervisor 
assignment, labor hours are displayed in the 
Time and Attendance Data Screen. 

Successful Supervisor 
Assignment 
(Search 
Criteria, 
Search) (60, 
61, 62) 

25 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Screen appears.   

26 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

Successful Employee 
Name (Date) 
(49) 
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Event # Action Expected Results  Observations  Requirements  
27 Verify that the Employee Name is 

highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

Tweety Bird’s labor hours are displayed in 
the Time and Attendance Data Screen. 

Successful Employee 
Name (Search 
Criteria, 
Search) (48, 
50, 51) 

28 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

29 Select Cancel. The Time and Attendance Week 2 (11-18-
00) window appears and changes were not 
saved to Week 1 (11-11-00). 

  

30 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday. Then select the Time and 
Attendance Week 2 (11-18-00).   

A message is displayed asking if the user 
wants to save changes. 

  

31 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

32 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

33 Select OK. A message appears stating that the 
validation and save were successful. 

  

34 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

35 Enter the following into the appropriate 
fields in the Week 1 Time and Attendance 
Data Screen for Tweety Bird: 
JON:  24681012 
S Shop:  No S Shop 

The data is entered in the appropriate fields. 
 
Note:  These are all optional field. 

Successful Time and 
Attendance 
(Data, JON, S 
Shop) (71, 72, 
74)  
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Event # Action Expected Results  Observations  Requirements  
36 Enter the wrong P Shop (05) in the P Shop 

field.  Then select the Save icon. 
An error message is displayed stating which 
field was in error. 
 
Note:  This is a MANDATORY field. 
 
Note:  Major error for the P shop, it will not 
allow you to save the P shop since it is a 
mandatory field. 

Successful Incorrect Data 
(36) Time and 
Attendance (P 
Shop) (73)  

37 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

38 Enter the correct P Shop (02) in the P 
Shop field. 

The P Shop is entered in the appropriate 
field. 
 

  

39 Enter in the following:  
Hazard Code: BA 
ND: spaces 
TYHR: CN 
Then click on the Save icon. 

An error message will be displayed 
indicating that Environmental Hazard BA 
cannot be used with type hour code CN. 
 
Note:  JON will default to nothing if it 
cannot find the JON. 

Successful Hz Code (75) 
Hz Code (D*, 
B*, E*, K*) 
(76) 

40 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

41 Enter in the following: 
Hazard Code: EA 
ND: ND 
TYHR: OA  
Then click on the Save icon. 

The following error messages will be 
displayed: Environmental Hazard Code EA 
and the Night Differential Code cannot be 
used with type hour code OA. 

Successful Update (42) 
TYHR 
(Environmenta
l) (94) 

42 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
43 Enter in the following: 

Hazard Code: BD 
ND: spaces 
TYHR: LW 
Then click on the Save icon. 

The following error message will be 
displayed: Environmental Hazard Code BD 
cannot be used with type hour code LW.  

Successful Update (Error) 
(44) TYHR  

44 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

45 Enter in the following: 
Hazard Code: FA 
ND: spaces 
TYHR: CT 
Then click on the Save icon. 

The following error message will be 
displayed: Environmental Hazard Code FA 
cannot be used with type hour code CT.  

Successful Update (Edit) 
(45) 

46 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

47 Enter in the following: 
Hazard Code: FB 
ND: spaces 
TYHR: LA  
Then click on the Save icon. 

The following error message will be 
displayed: Environmental Hazard Code FB 
cannot be used with type hour code LA.  

  

48 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

49 Enter in the following: 
Hazard Code: FD 
ND: spaces 
TYHR: LB 
Then click on the Save icon. 

The following error message will be 
displayed: Environmental Hazard Code FD 
cannot be used with type hour code LB.  

  

50 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
51 Enter in the following: 

Hazard Code: EC 
ND: ND 
TYHR: CA 
Then click on the Save icon. 

The data is changed and accepted. 
 
 
 

Failed 
 
TR #0003 

ND Code (Hz 
(Code) (84) 
 
 

52 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

53 Enter in the following: 
Hazard Code: DB 
ND: spaces 
TYHR: LO 
Then click on the Save icon. 

The data is accepted. 
 
 
 
Note:  The JON will be populated based on 
the other information input in the screen. 

Failed 
 
TR #0002 

TYHR (Hz) 
(95) 
 
 

54 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

55 Enter in the following: 
Hazard Code: DD 
ND: spaces 
TYHR: CT 
Then click on the Save icon. 

The data is changed and accepted. 
 
 
 

Successful 
 
TR #0002 
(Affecting 
Req. 95) 

TYHR (85) 
 
 

56 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

57 Enter in the following: 
Hazard Code: DD 
ND: spaces 
TYHR: LB 
Then click on the Save icon. 

The data is changed and accepted. 
 
 

TR #0002  

58 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
59 Enter in the following: 

Hazard Code: DB 
ND: spaces 
TYHR: LG 
Then click on the Save icon. 

The data is changed and accepted. 
 
 

TR #0002  

60 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

61 Enter in the following: 
Hazard Code: DD 
ND: spaces 
TYHR: LP 
Then click on the Save icon. 

The data is changed and accepted. 
 
 

TR #0002  

62 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

63 Enter in the following: 
Hazard Code: DB 
ND: spaces 
TYHR: LQ 
Then click on the Save icon. 

The data is changed and accepted. 
 
 

TR #0002  

64 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

65 Enter in the following: 
Hazard Code: DA 
ND: spaces 
TYHR: OA 
Then click on the Save icon. 

The following error message will be 
displayed: Environmental Hazard Code DA 
cannot be used with type hour code OA. 
 
 

TR #0002  

66 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
67 Enter in the following: 

Hazard Code: spaces 
ND: ND 
TYHR: CC 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code CC. 

Successful ND Code 
(Type Codes) 
(83) 

68 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

69 Enter in the following: 
Hazard Code: spaces 
ND: ND 
TYHR: CE 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code CE. 
 
 

  

70 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

71 Enter in the following: 
Hazard Code: spaces 
ND: ND 
TYHR: CR 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code CR. 

  

72 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

73 Enter in the following: 
Hazard Code: spaces 
ND: ND 
TYHR: OU 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code OU. 

  

74 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
75 Enter in the following: 

Hazard Code: spaces 
ND: ND 
TYHR: OC 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code OC. 

  

76 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

77 Enter in the following: 
Hazard Code: spaces 
ND: ND 
TYHR: OX 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code OX. 

  

78 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

79 Enter in the following: 
Hazard Code: spaces 
ND: ND 
TYHR: KB 
Then click on the Save icon. 

The following error message will be 
displayed: Night Differential Code cannot 
be used with type hour code KB. 

  

80 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

81 Enter in the following: 
TYHR: SF 
Then click on the Save icon. 

The following error message will be 
displayed: Must have hours on Saturday, 
Sunday or Monday. 

  

82 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

 GRADED BEGIN    
83 Enter in the following: 

TYHR: HF 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

Successful TYHR 
(Graded) (88) 

84 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  



 

C-1 

Event # Action Expected Results  Observations  Requirements  
85 Enter in the following: 

TYHR: HS 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

86 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

87 Enter in the following: 
TYHR: HT 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

88 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

89 Enter in the following: 
TYHR: RF 
Then click on the Save icon. 
 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

90 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

91 Enter in the following: 
TYHR: RT 
Then click on the Save icon. 
 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

92 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

93 Enter in the following: 
TYHR: RS 
Then click on the Save icon. 
 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

94 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

95 Enter in the following: 
TYHR: SF 
Then click on the Save icon. 
 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 
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Event # Action Expected Results  Observations  Requirements  
96 Close the error message. The Week 1 Time and Attendance Data 

Screen appears. 
  

97 Enter in the following: 
TYHR: SS 
Then click on the Save icon. 

The following error message will be 
displa yed: Ungraded type hour codes cannot 
be used for graded employees. 

  

98 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

99 Enter in the following: 
TYHR: ST 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded type hour codes cannot 
be used for graded employees. 

  

100 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 

  

 GRADED END    
101 Select the following in Week 1 Time and 

Attendance windows: 
JON: 24681012 
P Shop: 04 
TYHR: RG 

The information is displayed in the window.   

102 Change the hours to 8 for Tuesday.  Then 
select the Time and Attendance Week 2 
(11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

103 Select OK, then close the window. A message is displayed stating that the 
validation and save was successful, then 
closes. 
 
Note: Save performs an actual DB update. 

Successful Saved (28) 
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Event # Action Expected Results  Observations  Requirements  
104 Select Clocks Week 1 screen: 

Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

Failed 
 
TR #0005 

Clocks (107) 
 
 

105 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

106 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

Failed 
 
TR #0005 

Clocks (Week, 
Input, Delete) 
(108, 110, 111)  
 
 

107 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

108 Delete the Friday times in Week 2 Time 
and Attendance. 
 
Select the Save Icon. 

The hours are deleted.   

109 Close the validation message. The Week 2 Time and Attendance Data 
Screen appears. 

  

110 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

Failed 
 
TR #0004 

Work Schedule 
(109) 
 
 

111 Select the Week 1 Time and Attendance 
(11-11-00) window. 

The Week 1 Time and Attendance Data 
window is displayed. 

  

112 Enter 25 hours for Wednesday.  Then 
select the Save icon. 

An error message is displayed stating that 
the time entered is invalid. 

Successful Weekday (24 
Hours) (97) 

113 Close the error message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
114 Enter in –10 hours for Thursday. 

Then click on the Save icon. 
An error message is displayed stating that 
the hours cannot be non-negative. 

Successful Weekday (Non 
Negative) (98) 

115 Close the error message. The Week 2 Time and Attendance Data 
Screen appears. 

  

116 Enter 8 hours on a leave day (Saturday).  
Then click on the save icon. 

An error message appears stating that the 
user cannot enter hours on a scheduled day 
off. 

Successful Weekday 
(Leave) (99) 

117 Close the error message. The Week 2 Time and Attendance Data 
Screen appears. 

  

118 Enter 8 hours for Wednesday. 
Then click on the Save icon. 

The data is accepted. 
 
 

Successful Weekday 
Fields (96) 

119 Close the validation message. The Week 2 Time and Attendance Data 
Screen appears. 

  

120 Verify that the Overtime, Leave, Regular, 
Daily Total and the Grand Total of Hours 
can all be viewed in the Time and 
Attendance Data Window. 

The hours will be displayed. Successful Total (101) 
Overtime (102) 
Leave (103) 
Regular (104) 
Daily Totals 
(105) Grand 
Total (106) 

121 Select Certification>Correct and Certify 
from the SLDCADA Main Menu. 

The Search Screen appears. Successful Correct & 
Certify 
(Search) (116) 

122 Select the week ending date (12-3-00/12-
9-00). 

A statement appears stating “no values were 
found.” 

Successful Correct & 
Certify (Week) 
(117) 
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Event # Action Expected Results  Observations  Requirements  
123 Select a week ending date (11-12-00/11-

18-00) in the current pay period. 
The week ending date appears in the dialog 
box. 

  

124 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

The Certification Statement Window is 
displayed.   
 
Note:  Verify that a search can be performed 
by SSN, Supervisor Assignment and Shop. 

Successful Correct & 
Certify (Labor) 
(115) 

125 Select Decline. The Search window opens back up. Successful Correct & 
Certify 
(Decline) (113) 

126 Select a week ending date (11-12-00/11-
18-00) in the current pay period. 

The week ending date appears in the dialog 
box. 

  

127 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

The Certification Statement Window is 
displayed. 
 
 

  

128 Select Accept. The Correct and Certify window is 
displayed with Tweety Bird’s information 
on it. 

Successful Correct & 
Certify 
(Accept) (112, 
114) 

129 Change total hours to 8 for Monday-
Thursday for Week 2 Correct and Certify 
Data Screen. Then select Save. 

An error message is displayed stating that 
there are not enough hours for the days. 

Successful Weekday 
(Schedule) 
(100) 

130 Close the error message. The Week 2 Correct and Certify Data 
Screen appears. 

  

131 Change total hours to 9 Monday-Thursday 
and 8 Friday for Week 2 Correct and 
Certify Data Screen.  Then select Save. 

The data is saved. Successful Correct & 
Certify (View, 
Correct) (118, 
119) 

132 Close the validation message. The Week 2 Correct and Certify Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
133 Select the Clocks Week 2 tab from the 

Correct and Certify Data Screen, then 
return to the Correct and Certify Data 
Screen. 

The Week 2 Correct and Certify Data 
Screen is displayed. 
 
 

TR #0005  

134 Select the Week 1 Correct and Certify 
Data Screen. 

The Week 1 Correct and Certify Data 
Screen is displayed. 

  

135 Change hours for Monday-Thursday to 9 
hours for Week 1 Correct and Certify 
Data Screen.  Then select Save. 

The data is saved.   

136 Close the validation message. The Week 1 Correct and Certify Data 
Screen appears. 

  

137 Select the Cert. 1 icon. The certify button will be renamed “uncert 
1.” 
 
Note: The fields can no longer be updated 
unless the data is uncertified. 

Successful Week 1 (30) 
Correct & 
Certify (U) 
(120) 

138 Close the validation message. The Week 1 Correct and Certify Data 
Screen appears. 

  

139 Select the Uncert 1 button. The data is uncertified.   
140 Close the validation message. The Week 1 Correct and Certify Data 

Screen appears. 
  

141 Change Tuesday’s hours to 6 hours and 
Wednesday’s hours to 10 in the Week 1 
Correct and Certify Data Screen.  Then 
select the Save button. 

An error message is displayed stating that 
not enough hours were entered for Tuesday 
and too many for Wednesday.   

  

142 Close the error message. The Week 1 Correct and Certify Data 
Screen appears with the hours defaulted 
back to 9. 

  

143 Select the Clocks Week 1 tab from the 
Correct and Certify Data Screen, then 
return to the Week 2 Correct and Certify 
Data Screen. 

The Week 2 Correct and Certify Data 
Screen is displayed. 
 
 

TR #0005  
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Event # Action Expected Results  Observations  Requirements  
144 Select the Cert. 2 icon. The certify buttons will be renamed “Uncert 

2.” 
 
Note: The fields can no longer be updated 
unless the data is uncertified. 

Successful Week 2 (31) 

145 Close the validation message. The Week 2 Correct and Certify Data 
Screen appears. 

  

146 Select the Uncert 2 button. The data is uncertified.   
147 Close the validation message. The Week 2 Correct and Certify Data 

Screen appears. 
  

148 Select the Work Schedule icon. The Work Schedule is displayed. 
 
 

TR #0004  

149 Select Week 2 Correct and Certify Screen. The Week 2 Correct and Certify Screen is 
displayed. 

  

150 Select the Cert. Both Icon. Both weeks are certified. Successful Week 1 and 2 
(32) 

151 Close the validation message. The Week 2 Correct and Certify Data 
Screen appears. 

  

152 Select Certification>Certify Only from the 
SLDCADA Main Menu. 

The search screen is displayed.   

153 Select a week ending date (11-12-00/11-
18-00) in the current pay period. 

The week ending date appears in the dialog 
box. 

  

154 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

The Certification Statement Window is 
displayed. 
 
 

  

155 Select Decline. The Search window opens back up. Successful Certify (Deny) 
(122) Certify 
Only (Search) 
(125) 
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Event # Action Expected Results  Observations  Requirements  
156 Select the week ending date 12-3-00/12-9-

00. 
A statement appears stating that you cannot 
select a week ending date that is not in the 
current pay period. 

Successful Certify Only 
(Week) (126) 

157 Select a week ending date 11-12-00/11-
18-00. 

The week ending date appears in the dialog 
box. 

  

158 Verify that the SSN is highlighted in the 
Search Criteria box, select the employee’s 
SSN (230665779) from the Search 
Criteria Value pull down menu, then 
select Search. 

The Certification Statement Screen is 
displayed. 
 
Note: Verify that searches can be performed 
on Employee Name, Supervisor Assignment 
and Shop. 

Successful Certify Only 
(Labor, View) 
(124, 127) 

159 Select Accept. The Certify Only screen is displayed with 
Tweety Bird’s information on it. 
 

Successful Certify 
(Accept) (123) 

160 Select the Clocks Week 1 tab from the 
Certify Only Data Screen, then return to 
the Week 1 Certify Only Data Screen. 

The Week 1 Certify Only Data Screen is 
displayed. 
 
 

TR #0005  

161 Select the Uncert 1 icon. The uncertify buttons will be renamed “cert 
1.” 
 

Failed 
 
TR #0006 

Certify Only 
(121) 
 

162 Close the validation message. The Week 2 Certify Only Data Screen 
appears. 

  

163 Select Certification>Certify Only. The Search window is displayed.   
164 Select a week ending date (11-12-00/11-

18-00) in the current pay period. 
The week ending date appears in the dialog 
box. 

  

165 Verify that the Shop is highlighted in the 
Search Criteria box, then select ALL in 
the Search Criteria Value box, then select 
Search. 

The Certification Statement Window is 
displayed. 
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166 Select Accept. The Week 2 Certify Only screen is 

displayed with all of the shop’s information 
on it. 

  

167 Select Rusty Wallace. Rusty Wallace’s information appears on the 
screen. 

  

168 Select the Cert 2 icon. The Certify buttons will be renamed “uncert 
2.”  
 
 

TR #0006  

169 Close the validation message. The Week 2 Certify Only Data Screen 
appears. 

  

170 Select the Clocks Week 2 tab from the 
Certify Only Data Screen, then return to 
the Week 2 Certify Only Data Screen. 

The Week 2 Certify Only Data Screen is 
displayed. 
 
 

TR #0005  

171 Select the Work Schedule icon. The Work Schedule is displayed. 
 
 

TR #0004  

172 Select the Week 1 Certify Only Data 
Screen.  

The Week 1 Certify Only Data Screen is 
displayed. 

  

173 Select the Cert. Both Icon. Both weeks are certified. 
 
 

TR #0006  

174 Close the validation message. The Week 2 Certify Only Data Screen 
appears. 

  

175 Select Certification>Correct and Certify 
from the SLDCADA Main Menu. 

The Search Screen appears.   

176 Select a week ending date (11-12-00/11-
18-00) in the current pay period. 

The week ending date appears in the dialog 
box. 
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177 Verify that the Employee Name is 

highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

The Certification Statement Window is 
displayed. 
 
 

  

178 Select Accept. The Correct and Certify window is 
displayed with Tweety Bird’s information 
on it. 

  

179 Select the Uncert. Both Icon. Both weeks are uncertified.   
180 Select Employee>Payroll from the 

SLDCADA Main Menu. 
The Employee Search Screen is displayed. 
 
Note: Only Employee Name and SSN are 
available for the search criteria. 
 

Successful Employee 
Maintenance 
(Payroll, 
Name, SSN, 
Default) (128, 
129, 130, 131, 
132) 

181 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

182 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

Tweety Bird’s information is displayed in 
the Civilian Employee Payroll Data 
Maintenance Screen. 
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183 Verify that the Civilian Tab is selected, 

then select the following: 
Shop:  02 
Work Schedule: 1 
Time & Labor:  3 
Supv. Assignment: 1 
Badge Revision Number: 0 
Environmental Hazard:  
Status Code: A 
Union Unit Code: Union 
Direct/Indirect Code: Direct 
Saved Pay Indicator: N/A 
Temp Supv. Assignment: 
Geographic Location: 512690199 
Shifts Week 1: Sunday 00 
Monday-Saturday: 01 
Shifts Week 2: Sunday 00 
Monday-Tuesday, Friday E1 
Wednesday-Thursday, Saturday U1 

The information appears on the screen. 
 
Note:  The following are required fields: 
Employee Name, Shop, Work Schedule, 
Supervisor Assignment, Shift Assignment 
and Time and Labor Category. 
 
 

Successful Civilian 
(Select 
Information, 
Required) 
(133, 135, 137) 

184 Select the Reference List (?) next to the 
each item. 

The item codes are listed and described. Successful 
 
Failed  TR 
#0007 (Affects 
req. 37) 
 
 

Reference List 
(37) Civilian 
(Reference) 
(144) 
 
 

185 Close the Reference List. The reference list closes.   
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186 Enter in the following information: 

Sub Shop:  1212  
Pay Block: 4444 
Army AMS Code: 23423 
Stab Rate Category:   
Injury Date First:  

The information appears on the screen. 
 
 

Successful Civilian (Enter 
Information) 
(134) 

187 Verify that the following employee leave 
and HR information is displayed: 
Employing Activity: 000109 
Full/Part Time: F 
Employee Type Code: R 
Pay Plan: GS 
FLSA Indicator: E 
Graded Ungraded Indicator: G 
Pay Basis Code: Per Annum 
Basic Hourly Rate: 28.07 
Assigned Hourly Rate: 28.07 
Annual Salary: 58592.00 
COLA Rate: 0 
WG 10/2 Hourly Rate: 0 

The information is on the screen. 
 
Note: The following are required fields:  
Employing Activity, Geographic Location, 
Full/Part Time, Pay Plan, FLSA Indicator, 
Pay Plan, FLSA Indicator, 
Graded/Ungraded Indicator and Pay Basis 
Code. 
 
If Pay Basis Code is “Per Hour” these fields 
are mandatory:  Basic Hourly Rate, and 
Assigned Hourly Rate. 
 
If Pay Basis Code is “Per Annum” this field 
is mandatory: Annual Salary. 

Successful Civilian (HR) 
(136) 
 
 

188 Select the Civilian Predetermined tab in 
the Civilian Employee Payroll Data 
Maintenance Screen. 

The Civilian Employee Predetermined 
Payroll Data Maintenance screen appears. 

Successful Civilian 
(Predetermined
, Labor Data) 
(140, 141) 
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189 Enter the following into the Civilian 

Employee Predetermined Payroll Data 
Maintenance screen: 
JON:  24681012 
Expiration Date:  10/30/2024 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 02 

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day. 

Successful Civilian (JON, 
Hours Field, 
Expiration, 
Labor Hours, 
Shop, Codes) 
(142, 145, 148, 
149, 150, 151) 

190 Enter the following into the Civilian 
Employee Predetermined Payroll Data 
Maintenance screen: 
JON:  702244A 
Expiration Date:  10/30/2001 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 04 

The information appears on the screen.   

191 Enter the following into the Civilian 
Employee Predetermined Payroll Data 
Maintenance screen: 
JON:  SFKJ 
Expiration Date:  03/02/2001 
Hours: 24 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 01 

The information appears on the screen.   

192 Select the Add icon on the tool bar. A new row is added and loaded with any 
default values.   

Successful Add (29) 
Civilian (Add) 
(143) 
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193 Enter the following into the new row: 

JON:  24681012 
Expiration Date:  05/30/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop:  
 
Select Save. 

The information appears in the row.   
 

Successful Civilian (Work 
Field) (146) 

194 Select the box labeled MD next to the just 
added row. 

A check appears in the MD box.   

195 Select the save button. A message appears stating that records are 
marked for deletion. 
 
Note:  The record could just be deactivated 
if the record being deleted is in a code table 
used for validation. 

Successful Delete (MD) 
(46) Civilian 
(MD) (147) 

196 Select Cancel. A message appears stating that the save was 
cancelled. 

  

197 Select OK. The Civilian Predetermined Screen appears.   
198 Select Save. A message appears stating that records are 

marked for deletion. 
 
Note: Save does not have to be selected 
after each new row is added, only after all 
of the rows have been added. 

Successful Add (Execute, 
Success) (38, 
39) 

199 Select OK from the message. The record is deleted from the Civilian 
Predetermined Screen. 

  

200 Select the Leave Availability Tab. The Leave Availability for the employee is 
displayed. 
 
Note:  This screen can only be viewed. 

Successful Civilian 
(Leave) (152) 
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201 Select the MER tab. The Civilian Employee MER Data screen is 

displayed. 
 
Note: This screen can only be viewed. 

Successful Civilian 
(MER) (153) 

202 Select the BiMER (1) tab. The Civilian Employee BiMER (1) Data 
screen is displayed. 
 
Note: This screen can only be viewed. 

Successful Civilian 
(BiMER 1) 
(154) 

203 Select the BiMER (2) tab. The Civilian Employee BiMER (2) Data 
screen is displayed. 
 
Note: This screen can only be viewed. 

Successful Civilian 
(BiMER 2) 
(155) 

204 Select Employee>Field from the 
SLDCADA Main Menu. 

The Employee Search Screen is displayed. 
 
Note: Only Employee Name and SSN are 
available for the search criteria. 
 
Note:  If the user menu class is Self, no 
search windows can be accessed.  The user 
is taken directly to the Civilian Employee 
Data Maintenance Screen. 

Successful Field 
Employee 
Maintenance 
(Field, SSN, 
Default) (186, 
187, 189, 190) 

205 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

206 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

Tweety Bird’s information is displayed in 
the Civilian Employee Payroll Data 
Maintenance Screen. 
 

Successful Field 
Employee 
Maintenance 
(Name) (188) 
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207 Verify that the Civilian Tab is selected, 

then select the following: 
Shop:  02 
Rotation Code: 
Work Schedule: 1 
Time & Labor:  3 
Supv. Assignment: 1 
Environmental Hazard:  
Shifts Week 1: Sunday 00 
Monday-Saturday: 01 
Shifts Week 2: Sunday 00 
Monday-Tuesday, Friday E1 
Wednesday-Thursday, Saturday U1 

The information appears on the screen. 
 
 
 
 

Successful Field Civilian 
(Select 
Information, 
Required) 
(191, 194, 196) 

208 Select the Reference List (?) next to the 
items. 

The item codes are listed and described. Successful Field Civilian 
(Reference) 
(203) 

209 Close the Reference List. The reference list closes.   
210 Enter in the following information: 

Subshop: 1212 
Rotation Sequence: 
Injury Dates:  

The information appears on the screen. 
 
Note: Previous weeks displayed were 
accessed by query only. 

Successful Field Civilian 
(Query, Enter 
Information) 
(192, 193) 

211 Select the Civilian Predetermined tab in 
the Civilian Employee Field Data 
Maintenance Screen. 

The Civilian Employee Predetermined Field 
Data Maintenance screen appears. 

Successful Field Civilian 
(Predetermined
) (199) 
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212 Enter the following into the Civilian 

Employee Predetermined Field Data 
Maintenance screen: 
JON:  24681012 
Expiration Date:  10/30/2024 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 02 

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day. 

Successful Field Civilian 
(Labor Data, 
JON, Hours 
Field, Work 
Field, 
Expiration, 
Labor Hours, 
Shop, Codes) 
(200, 201, 204, 
205, 207, 208, 
209, 210)  

213 Enter the following into the Civilian 
Employee Predetermined Field Data 
Maintenance screen: 
JON:  702244A 
Expiration Date:  10/30/2001 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 04 

The information appears on the screen.   

214 Enter the following into the Civilian 
Employee Predetermined Field Data 
Maintenance screen: 
JON:  SFKJ 
Expiration Date:  03/02/2001 
Hours: 24 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 01 

The information appears on the screen.   

215 Select the Add icon on the tool bar. A new row is added and loaded with any 
default values.   

Successful Field Civilian 
(Add) (202) 
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216 Enter the following into the new row: 

JON:  24681012 
Expiration Date:  05/30/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop:  
 
Select Save. 

The information appears in the row.   
 

  

217 Select the box labeled MD next to the just 
added row. 

A check appears in the MD box. Successful Field Civilian 
(MD) (206) 

218 Select the save button. A message appears stating that records are 
marked for deletion. 
 
Note:  The record could just be deactivated 
if the record being deleted is in a code table 
used for validation. 

  

219 Select Cancel. A message appears stating that the save was 
cancelled. 

  

220 Select OK. The Civilian Predetermined Screen appears.   
221 Select Save. A message appears stating that records are 

marked for deletion. 
 
Note: Save does not have to be selected 
after each new row is added, only after all 
of the rows have been added. 

  

222 Select OK from the message. The record is deleted from the Civilian 
Predetermined Screen. 

  

223 Select the Leave Availability Tab. The Leave Availability for the employee is 
displayed. 
 
Note:  This screen can only be viewed. 

Successful Field Civilian 
(Leave) (211) 
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224 Select the MER tab. The Civilian Employee MER Data screen is 

displayed. 
 
Note: This screen can only be viewed. 

Successful Field Civilian 
(MER) (212) 

225 Select the BiMER (1) tab. The Civilian Employee BiMER (1) Data 
screen is displayed. 
 
Note: This screen can only be viewed. 

Successful Field Civilian 
(BiMER 1) 
(213) 

226 Select the BiMER (2) tab. The Civilian Employee BiMER (2) Data 
screen is displayed. 
 
Note: This screen can only be viewed. 

Successful Field Civilian 
(BiMER 2) 
(214) 

227 Select Reports>Cert List-Cert Emp Rpt. The Search Screen is displa yed. Successful Certified 
Report (247) 

228 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

229 Verify that the Shop is highlighted in the 
Search Criteria box, then enter Employee 
Activity (000109) into the Search Criteria 
Value box, then select Search. 

The Employee with Employee Activity 
number 000109 is listed in the Certified 
Employee Report.  All other certified 
employees are also listed. 

  

230 Select File>Save As, then name it 
Certified Employees. 

The Report is archived for history purposes. Successful Certified 
Report (Save) 
(248) 

231 Select File>Print. The Report is printed. Successful Certified 
Report (Print) 
(249) 

232 Close the Certified Employees Report 
Screen. 

The screen closes to the BiMER 2 Screen.   

233 Select Reports>Cert List-UnCert Emp 
Rpt. 

The Search Screen is displayed. Successful Manual Report 
(250) 

234 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 
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235 Verify that the Employee Name is 

highlighted in the Search Criteria box, 
then enter the employee’s name (Tweety 
Bird) into the Search Criteria Value box, 
then select Search. 

The Certification Listing for Manually 
Certified Employees Report is displayed. 
 

  

236 Select File>Print. The Report is printed. Successful Manual Report 
(Print) (251) 

237 Close the Certified Employees Report 
Screen. 

The screen closes to the BiMER 2 Screen.   

238 Select Reports>Incorrect Hours. The Search Screen is displayed. 
 
 

Successful Incorrect 
Report (Query) 
(252, 253) 

239 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

240 Verify that the Shop is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

The Incorrect Hours Report appears 
displaying employees whose daily hours do 
not match their work schedule. 
 

  

241 Close the Incorrect Hours Report. The screen closes to the BiMER 2 Screen.   
242 Select Reports>Missing Timecards. The Search Screen appears. Successful Missing Report 

(254) 
243 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 

  

244 Verify that the Shop is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

All of the employees with missing 
timecards are displayed. 
 

  

245 Close the Missing Time Cards Report. The screen closes to the BiMER 2 Screen.   
246 Select Reports>Uncertified Employees. The Uncertified Employees Report appears 

displaying all employees who have not been 
certified. 

Successful Uncertified 
Report (255) 
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247 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 

  

248 Verify that the UIC is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

All uncertified employees are listed in the 
Uncertified Employees Report. 
 

Successful UIC (Search 
Criteria, 
Search, 
Conduct) (63, 
64, 65) 

249 Close the Uncertified Employees Report. The screen closes to the BiMER 2 Screen.   
250 Select the Exit SLDCADA from the 

SLDCADA Main Menu. 
SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

251 Select Cancel. The screen closes to the BiMER 2 Screen.   
252 Select the Exit SLDCADA from the 

SLDCADA Main Menu. 
SLDCADA is exited and the user is 
returned to the Netscape browser. 

Successful Exit (263) 

253 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 



 

C-1 

SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 1 4.3 Launch Allows access to SLDCADA through Internet Explorer. P 1 

 2 4.3.1 New Site Provides the user the ability to process a New Site certificate. NT SLDCADA-0013 4 

 3 4.3.1 New Site (Bypass) Allows the user to bypass the New Site Certificate process when  NT SLDCADA-0013 4 
 you access the SLDCADA web. 

 4 4.3.1 New Site (Accept) Allows the user to accept the certificate for this session only. NT SLDCADA-0013 4 

 5 4.3.1 New Site (Not Accepted) Allows the user to not accept the certificate and not connect to  NT SLDCADA-0013 4 
 the web. 

 6 4.3.1 New Site (Warn) Allows the user to be warned before sending information to the  NT SLDCADA-0013 4 
 site. 

 7 4.3.1 New Site (Don't Warn) Allows the user to not be alerted before information is sent to the  NT SLDCADA-0013 4 
 site. 

 8 4.3.1 Security Provides the ability to be alerted when accessing a secure site. NT SLDCADA-0013 4 

 9 4.3.1 Security (Not Displayed) Provides the ability to not be alerted when accessing a secure  NT SLDCADA-0013 4 
 site. 

 10 4.3.1 Security Alert Allows the user to proceed at the Security Alert window. NT SLDCADA-0013 4 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 11 4.3.1 Security Alert (Proceed) Allows the user not to proceed at the Security Alert window. NT SLDCADA-0013 4 

 12 4.3.1 Security Alert (Certificate) Allows the user to view the certificate at the Security Alert  NT SLDCADA-0013 4 
 window. 

 13 4.3.3 User ID Allows only users with valid usernames and passwords to  P 1 
 proceed. 

 14 4.3.3 Cancel Allows the termination of the SLDCADA at the login screen. P 4 

 15 4.3.3 Invalid Login Provides the ability to login again if an invalid login error  P 4 
 occurs. 

 16 4.3.3 Login Error Capability to display a login error message after the second time a  P 4 
 login is attempted. 

 19 4.3.3 Cancel Password Provides the user the ability to return to the login screen from the  NT SLDCADA-0013 4 
 Change Password screen. 

 24 4.4.1 About SLDCADA Provides basic information about SLDCADA. P 4 

 25 4.4.1 Menu Bar Present all menu options that are currently available. P 1 

 26 4.4.1 Status Bar Display line for displaying prompts and informational messages. P 4 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 27 4.4.1 Tool Bar Allows the viewing of all icons the user has access to, displaying P 1 
  the Icon functions in text.  (Graying out those user cannot  
 access).  

 28 4.4.2 Saved Performs a save to the database. P 1 

 29 4.4.2 Add Add a new row to the window, with the record added appearing  P 1 
 at the end of the rest of the data. 

 30 4.4.2 Week 1 Provides the ability to certify or uncertify week 1 labor of the  P 1 
 currently selected employee. 

 31 4.4.2 Week 2 Provides the ability to certify or uncertify week 2 labor of the  P 1 
 currently selected employee. 

 32 4.4.2 Week 1 and 2 Provides the ability to certify or uncertify week 1 and 2 labor of  P 4 
 the currently selected employee. 

 33 4.4.2 Current User Provides the ability to obtain the information concerning the user P 4 
  logged into SLDCADA. 

 34 4.4.2 Current Week Provides the ability to identify the current SLDCADA week  P 4 
 ending date. 

 35 4.4.2 Help Provides access to the online help function. F SLDCADA-0001 4 

 36 4.4.3 Incorrect Data Provides the ability to notify the user when information is  P 2 
 entered incorrectly, in an improper format or due to a system  
 problem. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 37 4.4.3 Reference List Allows the user to access reference lists throughout the  F SLDCADA-0007 3 
 application. 

 38 4.5.1 Add (Execute) Provide the user the ability to add a record. P 1 

 39 4.5.1 Add (Success) Provides the user the ability to know if the add was completed  P 4 
 successfully. 

 40 4.5.1 Add (Error) Provide an error message if the Add edit fails. NT SLDCADA-0013 3 

 41 4.5.1 Add (Edit) Provide the ability to edit the error and attempt the add again. NT SLDCADA-0013 3 

 42 4.5.2 Update Provide the user the ability to update a record. P 1 

 43 4.5.2 Update (Success) Provides the ability for the user to that the update was successful  NT SLDCADA-0013 4 
 by t he record number turning green. 

 44 4.5.2 Update (Error) Provide an error message if the update fails and the record number  P 3 
 turns red. 

 45 4.5.2 Update (Edit) Provide the ability to edit the error and attempt the update again. P 3 

 46 4.5.3 Delete (MD) Provide the ability to delete a record. P 1 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 48 4.6.1 Employee Name Provide the ability to use Employee Name as a search criteria. P 3 

 49 4.6.1 Employee Name (Date) Provide the ability to conduct an employee name search by the  P 1 
 desired date. 

 50 4.6.1 Employee Name (Search  Provide the ability to enter the first letter of an employee's name  P 4 
 Criteria) as a search criteria value and select the name desired. 

 51 4.6.1 Employee Name (Search) Provide the user the ability to conduct a search on an employee  P 3 
 name. 

 52 4.6.1 Employee Name (Cancel) Provide the user the ability to cancel a search. P 4 

 53 4.6.2 Shop Provide the ability to use Shop as a search criteria. P 3 

 54 4.6.2 Shop (Search Criteria) Provide the ability to select a shop as a search criteria value. P 3 

 55 4.6.2 Shop (Default) Capability to default to one shop if it is the only one assigned. P 4 

 56 4.6.2 Shop (Searc h) Provide the user the ability to conduct a search on a shop. P 3 

 57 4.6.3 SSN Provide the ability to use Social Security Number as a search  P 3 
 criteria. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 58 4.6.3 SSN (Search Criteria) Provide the ability to enter the first number of an employee's SSN  P 4 
 as a search criteria value and select the SSN desired. 

 59 4.6.3 SSN (Search) Provide the user the ability to conduct a search using the SSN. P 3 

 60 4.6.4 Supervisor Assignment  Provide the ability to use Supervisor Assignment as a search  P 3 
 criteria. 

 61 4.6.4 Supervisor Assignment  Provide the ability to select a Supervisor Assignment as a search  P 3 
 (Search Criteria) criteria value. 

 62 4.6.4 Supervisor Assignment  Provide the user the ability to conduct a search by using the  P 3 
 Supervisor Assignment. 

 63 4.6.5 UIC (Search Criteria) Provide the ability to use UIC as a search criteria. P 3 

 64 4.6.5 UIC (Search) Provide the ability to select a UIC as a search criteria value. P 3 

 65 4.6.5 UIC (Conduct) Provide the user the ability to conduct a search by using the UIC. P 3 

 69 4.7.1.1 Time & Attendance (Default) Provide the ability for the user to be unable to access any of the  P 4 
 search windows and be taken directly to the Time & Attendance  
 Data Screen. 

 70 4.7.1.1 Time and Attendance (Search) Allows the user to search in the Time and Attendance window by  P 3 
 Employee Name, SSN, Shop or Supervisor Assignment. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 71 4.7.1.2 Time & Attendance (Data) Provide the ability to enter, edit, display an employee's labor  P 1 
 data. 

 72 4.7.1.3 Time & Attendance (JON) Provide the ability to enter, edit, display an employee's standing  P 1 
 Job Order Number (JON). 

 73 4.7.1.3 Time & Attendance (P Shop) Provide the ability to enter, edit, display an employee's  P 1 
 Performance Shop as a mandatory field. 

 74 4.7.1.3 Time & Attendance (S Shop) Provide the ability to enter, edit, display an employee's Sub shop. P 1 

 75 4.7.1.3 Hz Code  Provide the ability to enter, edit, display an employee's  P 1 
 Environmental Hazard Code. 

 76 4.7.1.3 Hz Code (D*, B*, E*, F*) Capability to use Environment Hazard Codes D*, B*, E* and F*  P 3 
 when the type hour codes = CN, CT, KA, LA, LB, LG, LP, LQ,  
 LR, LS, or LW. 

 83 4.7.1.3 ND Code (Type Codes) Capability for Night Differential Code to not be used with type  P 3 
 hour codes = CC, CD, CE, CR, OA, OC, OU, OX or *K.  

 84 4.7.1.3 ND Code (Hz Code) Allows the user to use Environmental Hazard Codes for use with  F SLDCADA-0003 3 
 Night Differential codes: EC, EH, ES, EV, EG, EQ, ET, EW, E1-6, 
  FC, FE, FG, FQ, FR, FU, F5, F6. 

 85 4.7.1.3 TYHR Provide the ability to enter, edit, display an employee's TYHR  P 1 
 (Type Hour Code) as a mandatory field. 

 88 4.7.1.3 TYHR (Graded) Deny Graded Type Hour Codes HG, RG, or SG to be used for  P 3 
 ungraded employees. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 90 4.7.1.3 TYHR (Sunday) Capability to use Sunday Type Hour Codes (S*) only when hours NT SLDCADA-0013 3 
  on Saturday, Sunday, or Monday. 

 91 4.7.1.3 TYHR (Alternate) Deny Alternate Work Schedule Codes 0, 6, 7, and 8 with the use  NT SLDCADA-0013 3 
 of Type Hour Codes CD or CN. 

 94 4.7.1.3 TYHR (Environmental) Deny Environmental Hazard Code B*, E*, or F* when used with  P 3 
 Type Hour Codes K*, L* (Except LT, LN, and LU), CA, CN, CT,  
 OA, or ON. 

 95 4.7.1.3 TYHR (Hz) Capability to use Environmental Hazard Code D* with Type  F SLDCADA-0002 3 
 Hour Codes CN, CT, KA, LA, LB, LG, LO, LP, LQ, LR, LS, and  
 LW. 

 96 4.7.1.3 Weekday Fields Capability to enter valid work scheduled hours in the following  P 1 
 fields: Sun, Mon, Tue, Wed, Thu, Fri, and Sat. 

 97 4.7.1.3 Weekday (24 Hours) Allows the user not to exceed 24 hours in any one day. P 3 

 98 4.7.1.3 Weekday (Non Negative) Allows the user not to enter non negative hours on any one day. P 3 

 99 4.7.1.3 Weekday (Leave) Allows the user not to enter regular or leave hours on a scheduled P 3 
  day off. 

 100 4.7.1.3 Weekday (Schedule) Hours must total 40 or 80 hours (depending on schedule) for  P 3 
 AWS 3, 4, 5, 7, D, or E. 

 101 4.7.1.3 Total Provide the ability to view total hours by Type Hour Code. P 4 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 102 4.7.1.3 Overtime Provide the ability to view total overtime and comp hours earned  P 4 
 for type hour codes CC, CD, CE, CR, HC, HF, HG, HS, HT, OA,  
 OC, OS, OU and OX. 

 103 4.7.1.3 Leave Provide the ability to view total leave hours for type hour codes  P 4 
 CA, CN, CT, LA, LB, LC, LF, LG, LH, LI, LJ, LK, LL, LN, LP,  
 LQ, LR, LS, LT, LU, LV, LW, LX and LY. 

 104 4.7.1.3 Regular Provide the ability to view total regular hours for type hour  P 4 
 codes RF, RG, RS, RT, RX, SF, SG, SS and ST. 

 105 4.7.1.3 Daily Totals Provide the ability to view total hours per day. P 4 

 106 4.7.1.3 Grand Total Provide the ability to view total hours for the week. P 4 

 107 4.7.1.2 Clocks Allows the user to view the clock in/ out times for the first week  F SLDCADA-0005 2 
 of the pay period. 

 108 4.7.1.2 Clocks (Week) Allows the user to view the clock in/ out times for the second  F SLDCADA-0005 2 
 week of the pay period. 

 109 4.7.1.2 Work Schedule Allow the user to view a selected employee's work schedule. F SLDCADA-0004 3 

 110 4.7.1.4 Clocks (Input) Allows the user to input clock in/out times for week one and  F SLDCADA-0005 2 
 week two. 

 111 4.7.1.4 Clocks (Delete) Allows the user to delete a time from the clock screens for week  F SLDCADA-0005 2 
 one and week two. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 112 4.8.1 Correct & Certify Provide the user the ability to modify the time and attendance  P 3 
 data prior to certification. 

 113 4.8.1 Correct & Certify (Decline) Provide the user the ability to decline the Certification Statement  P 3 
 and return to the Labor Menu. 

 114 4.8.1 Correct & Certify (Accept) Allow the user to enter the Correct and Certify Data Screen by  P 1 
 accepting the Certification Statement. 

 115 4.8.1 Correct & Certify (Labor) Allow the user to specify the individual or group to be certified  P 3 
 in labor. 

 116 4.8.1.1 Correct & Certify (Search) Allow the user to search for the individual by Employee Name,  P 3 
 SSN, Shop or Supervisor Assignment. 

 117 4.8.1.1 Correct & Certify (Week) Allow the user to only certify a week ending date for the current  P 4 
 pay period. 

 118 4.8.1.2 Correct & Certify (View) Allow the user to view a selected employee's labor data. P 1 

 119 4.8.1.2 Correct & Certify (Correct) Allow the user to make any corrections to the individuals hours  P 3 
 and in/out times. 

 120 4.8.1.2 Correct & Certify (U) Capability to rename the certify buttons to "UNCERT". P 4 

 121 4.8.1.3 Certify Only Allow the user to certify the labor of an individual. F SLDCADA-0006 1 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 122 4.8.1.3 Certify (Deny) Provide the user the ability to decline the Certification Statement  P 3 
 and return to the Labor Menu. 

 123 4.8.1.3 Certify (Accept) Allow the user to enter the Certify Only Screen by accepting the  P 3 
 Certification Statement. 

 124 4.8.1.4 Certify Only (Labor) Allow the user to specify the individual to be certified in labor. P 3 

 125 4.8.1.4 Certify Only (Search) Allow the user to specify the individual by Employee Name, SSN, P 3 
  Shop or Supervisor Assignment. 

 126 4.8.1.4 Certify Only (Week) Allow the user to certify a week ending date for the current pay  P 3 
 period. 

 127 4.8.1.4 Certify Only (View) Allow the user to view a selected employee's labor data. P 3 

 128 4.9 Employee Maintenance  Provides the ability to access payroll from the employee menu. P 1 

 129 4.9.1 Employee Maintenance Provides the ability for the user to enter and maintain payroll data P 1 
  for employees by the payroll office. 

 130 4.9.1.1 Employee Maintenance  Allows the user to specify the individual by name to be reviewed  P 3 
 or updated through the payroll search criteria. 

 131 4.9.1.1 Employee Maintenance (SSN) Allows the user to specify the individual by SSN to be reviewed  P 3 
 or updated through the payroll search criteria. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 132 4.9.1.1 Employee Maintenance  Capability to default the user class as self if the user is identified  P 4 
 (Default) in a search, the user then cannot access any of the search  
 windows. 

 133 4.9.1.2 Civilian Allows the user to maintain civilian employee data.   P 1 

 134 4.9.1.2 Civilian (Enter Information) Allows the user to enter the following information in the Civilian P 1 
  Employee Data Maintenance Screen:  Sub shop, Pay block, Army  
 AMS Code, Stab Rate Category, Injury Dates. 

 135 4.9.1.2 Civilian (Select Information) Allows the user to view and select from a pull down menu in the  P 1 
 Civilian Employee Data Maintenance Screen:  Shop, Work  
 Schedule, Time and Labor Category, Supervisor Assignment,  
 Badge Revision Number, Environmental Hazard, Status Code,  
 Union Unit Code, Direct/Indirect Code, Saved Pay Indicator,  
 Temporary Supervisor Assignment and Geographic Location. 

 136 4.9.1.2 Civilian (HR) Provides the ability for the user to view the Civilian Employee's  P 3 
 Human Resource Information in the Civilian Employee Data  
 Maintenance Screen. 

 137 4.9.1.2 Civilian (Required) Allows the user to input information into the required fields:  P 3 
 Employee Name, Geographic Location, Ship, Full/Part Time,  
 Work Schedule, Pay Plan, Supervisor Assignment, FLSA  
 Indicator, Shift Assignment, Graded/Ungraded Indicator, Time &  
 Labor Category, Pay Basis code, Employing Activity. 

 140 4.9.1.2 Civilian (Predetermined) Provides the ability to maintain a civilian employee's  P 3 
 predetermined labor data. 

 141 4.9.1.2 Civilian (Labor Data) Allows the user to access the Civilian Predetermined labor data. P 3 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 142 4.9.1.2 Civilian (JON) Provides the ability to enter up to 99 Job Order Numbers for a  P 3 
 civilian employee. 

 143 4.9.1.2 Civilian (Add) Allows the user to add a row and enter the Job Order Numbers for  P 3 
 each civilian employee. 

 144 4.9.1.2 Civilian (Reference) Capability to use the reference list for the civilian Job Order  P 4 
 Numbers and display the Job Order Numbers on the labor screens. 

 145 4.9.1.2 Civilian (Hours Field) Provides the ability to generate civilian hours according to the  P 3 
 Hours field per day. 

 146 4.9.1.2 Civilian (Work Field) Provides the ability to generate civilian hours according to the  P 3 
 work schedule.   

 147 4.9.1.2 Civilian (MD) Allows the user to delete a civilian Job Order Number record. P 3 

 148 4.9.1.2 Civilian (Expiration) Allows the user to enter the civilian Job Order Number expiration P 3 
  date. 

 149 4.9.1.2 Civilian (Labor Hours) Allows the user to enter the civilian Job Order Number labor  P 3 
 hours. 

 150 4.9.1.2 Civilian (Shop) Allows the user to choose the civilian Job Order Number's  P 3 
 benefiting shop. 

 151 4.9.1.2 Civilian (Codes) Allows the user to enter the civilian Labor Class and Operation  P 3 
 Codes. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 152 4.9.1.2 Civilian (Leave) Provides the ability to view data only from the Civilian  P 4 
 Employee Leave Availability Data Maintenance Screen. 

 153 4.9.1.2 Civilian (MER) Provides the ability to view data only from the Civilian  P 4 
 Employee MER Data Screen. 

 154 4.9.1.2 Civilian (BiMER 1) Provides the ability to view data only from the Civilian  P 4 
 Employee BiMER (1) Data Screen. 

 155 4.9.1.2 Civilian (BiMER 2) Provides the ability to view data only from the Civilian  P 4 
 Employee BiMER (2) Data Screen. 

 186 4.9.2 Employee Maintenance (Field) Provides the ability to access field from the employee menu. P 3 

 187 4.9.2 Field Employee Maintenance Provides the ability for the individual to enter and maintain  P 3 
 certain payroll data for employees. 

 188 4.9.2.1 Field Employee Maintenance  Allows the user to specify the individual by name to be reviewed  P 3 
 (Name) or updated through the field search criteria. 

 189 4.9.2.1 Field Employee Maintenance  Allows the user to specify the individual by SSN to be reviewed  P 3 
 (SSN) or updated through the field search criteria. 

 190 4.9.2.1 Field Employee Maintenance  Capability to default the user class as self if the user is identified  P 4 
 (Default) in a search, the user then cannot access any of the search  
 windows. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 191 4.9.2.2 Field Civilian Allows the user to maintain civilian employee data.   P 3 

 192 4.9.2.2 Field Civilian (Query) Provides the ability to access all data displayed for previous  P 3 
 weeks by query only. 

 193 4.9.2.2 Field Civilian (Enter  Allows the user to enter the following information in the Civilian P 3 
 Information)  Employee Data Maintenance Screen:  Sub shop and Injury Dates. 

 194 4.9.2.2 Field Civilian (Select  Allows the user to view and select from a pull down menu in the  P 3 
 Information) Civilian Employee Data Maintenance Screen:  Shop, Work  
 Schedule, Time and Labor Category, Supervisor Assignment and  
 Environmental Hazard. 

 196 4.9.2.2 Field Civilian (Required) Allows the user to input information into the required fields:  P 3 
 Work Schedule, Supervisor Assignment, Shift Assignment and  
 Time & Labor Category. 

 199 4.9.2.2 Field Civilian (Predetermined) Provides the ability to maintain a civilian employee's  P 3 
 predetermined labor data. 

 200 4.9.2.2 Field Civilian (Labor Data) Allows the user to access the Civilian Predetermined labor data. P 3 

 201 4.9.2.2 Field Civilian (JON) Provides the ability to enter up to 99 Job Order Numbers for a  P 3 
 civilian employee. 

 202 4.9.2.2 Field Civilian (Add) Allows the user to add a row and enter the Job Order Numbers for  P 3 
 each civilian employee. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 203 4.9.2.2 Field Civilian (Reference) Capability to use the reference list for the civilian Job Order  P 4 
 Numbers and display the Job Order Numbers on the labor screens. 

 204 4.9.2.2 Field Civilian (Hours Field) Provides the ability to generate civilian hours according to the  P 3 
 Hours field per day. 

 205 4.9.2.2 Field Civilian (Work Field) Provides the ability to generate civilian hours according to the  P 3 
 work schedule.   

 206 4.9.2.2 Field Civilian (MD) Allows the user to delete a civilian Job Order Number record. P 3 

 207 4.9.2.2 Field Civilian (Expiration) Allows the user to enter the civilian Job Order Number expiration P 3 
  date. 

 208 4.9.2.2 Field Civilian (Labor Hours) Allows the user to enter the civilian Job Order Number labor  P 3 
 hours. 

 209 4.9.2.2 Field Civilian (Shop) Allows the user to choose the civilian Job Order Number's  P 3 
 benefiting shop. 

 210 4.9.2.2 Field Civilian (Codes) Allows the user to enter the civilian Labor Class and Operation  P 3 
 Codes. 

 211 4.9.2.2 Field Civilian (Leave) Provides the ability to view data only from the Civilian  P 4 
 Employee Leave Availability Data Maintenance Screen. 

 212 4.9.2.2 Field Civilian (MER) Provides the ability to view data only from the Civilian  P 4 
 Employee MER Data Screen. 
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SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 213 4.9.2.2 Field Civilian (BiMER 1) Provides the ability to view data only from the Civilian  P 4 
 Employee BiMER (1) Data Screen. 

 214 4.9.2.2 Field Civilian (BiMER 2) Provides the ability to view data only from the Civilian  P 4 
 Employee BiMER (2) Data Screen. 

 247 4.10.1 Certified Report Allows the user to view the Certification Listing for Certified  P 4 
 Employee Report displaying the employee that were  
 electronically certified. 

 248 4.10.1 Certified Report (Save) Provides the ability to archive (save) the Certification Listing for  P 4 
 Certified Employee Report for history purposes. 

 249 4.10.1 Certified Report (Print) Provides the ability to print the Certification Listing for Certified P 4 
  Employee Report for history purposes. 

 250 4.10.2 Manual Report Allows the user to view the Certification Listing For Manually  P 4 
 Certified Employees Report displaying the employees that were  
 not electronically certified. 

 251 4.10.2 Manual Report (Print) Provides the ability to print the Certification Listing for  P 4 
 Manually Certified Employee Report. 

 252 4.10.3 Incorrect Report  Allows the user to view the Incorrect Hours Report displaying  P 4 
 employees with hours that do not match their scheduled hours. 

 253 4.10.3 Incorrect Report (Query) Provides the ability to query the Incorrect Hours Report by  P 4 
 Supervisor Assignment, Employee Name, SSN or Shop after all  
 hours have been entered. 

 254 4.10.4 Missing Report Allows the user to view the Missing Timecards Report  P 4 
 displaying a list of employees for whom no labor records have  
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 been save or have been skipped. 



 

C-1 

SLDCADA Requirements List for Test Case CIVILIAN SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 255 4.10.5 Uncertified Report Allows the user to view the Uncertified Employees Report  P 4 
 displaying employee labor data for employees who have not been  
 certified. 

 258 4.10.6 Help Provides the user with various help information concerning  F SLDCADA-0001 4 
 SLDCADA. 

 259 4.10.7 User Information Allows the user to view the information concerning the user  P 4 
 logged into SLDCADA. 

 260 4.10.7 Current User Report Provides the ability to close the Current User Information Screen. P 4 

 261 4.10.8 Week Ending Information Allows the user to view the current SLDCADA Week Ending  P 4 
 Date. 

 262 4.10.8 Current Week Ending Provides the ability to close the Current Week Ending Date  P 4 
 Information Screen. 

 263 4.10.8 Exit Provides the ability for the user to exit the SLDCADA and return  P 4 
 to the Netscape browser. 
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1.   Details of Test Case: STD 2-Military SE/SE Inquiry Only 
 
 
1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian , military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type 
hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code Self and have access rights only to Self.   
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STD 2-Military SE/SE Inquiry Only 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: beverly 
Password: beverly_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: beverly 
New Password: saints_1 
Confirm New Password: saints_1 
Then select Submit. 

The Successful Password Change window 
appears. 

Successful Default 
Password (17) 
Successful 
Password (20) 

5 Select OK. The Employee Type Screen is displayed.   
6 Select Military and then select Submit. SLDCADA System News Screen is 

displayed. 
 
Note:  A news and broadcast message 
appears on entry when using the 
SLDCADA web version. 

Successful Submit 
Password (18) 
Employee 
Type (22) 
System News 
Screen (23)  

7 Select Tools>Change Password. The password utility screen appears.   
8 Select OK and type in the following: 

New Password: saints_2 
Confirm New Password: saints_2 
Then select Submit. 

The Successful Password Change window 
appears. 

Successful Password 
(Tool Bar) (21) 

9 Select OK. The SLDCADA News Screen appears.   
 



 

C-1 

Event # Action Expected Results  Observations  Requirements  
10 Select the Help>Help Topics from the 

SLDCADA Main Menu, then close the 
screen. 

The Help menu is displayed and closed. 
 
 

TR #0001  

11 Select the Help>About from the 
SLDCADA Main Menu, then close the 
screen. 

The About SLDCADA Screen appears and 
closes. 

  

12 Select the Tools>User Login Information 
from the SLDCADA Main Menu, then 
close the screen. 

The Current screen is displayed showing the 
current user logged into SLDCADA, then 
the screen closes. 

  

13 Select the Tools>Current Week 
Information from the SLDCADA Main 
Menu, then close the screen. 

The Current Week Ending Date Information 
screen appears showing the weekend date, 
then the screen closes. 

  

14 Verify that the SLDCADA Status Bar is 
displayed at the bottom of the screen. 

The Status Bar is displayed on the screen.   

15 Select Tools>System News from the 
SLDCADA Main Menu. 

The System News Screen appears.   

16 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 
Note:  The user is logged in as self so only 
the user is displayed, therefore, no search 
options are available. 

  

17 Select the Military Beverly Garland. Military Beverly Garland is highlighted.   
18 Enter the following information: 

JON: 62R240Y 
P Shop: 03 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

19 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 
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Event # Action Expected Results  Observations  Requirements  
20 Select Time and Attendance Week 1 (11-

11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

21 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

22 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

23 Select OK. A message appears stating that the 
validation and save were successful. 

  

24 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

 MILITARY BEGIN    
25 Enter in the following: 

Hazard Code: EA 
ND: spaces 
Then click on the Save icon. 

The following error message will be 
displayed: Military, SES, and Firefighters 
cannot use Environmental Code. 

Successful Hz Code 
(Military) (77) 

26 Close the error message. The Week 1 Time and Attendance Screen is 
displayed. 

  

27 Enter in the following: 
Hazard Code: BA 
ND: spaces 
Then click on the Save icon. 

The following error message will be 
displayed: Military, SES, and Firefighters 
cannot use Environmental Code. 

  

28 Close the error message. The Week 1 Time and Attendance Screen is 
displayed. 

  

29 Enter in the following: 
Hazard Code: spaces 
ND: ND 
Then click on the Save icon. 

The following error message will be 
displayed: Military (employee type = M or 
B) cannot use Night Differential Code. 

Successful ND Code 
(Military) (80) 
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Event # Action Expected Results  Observations  Requirements  
30 Close the error message. The Week 1 Time and Attendance Screen is 

displayed. 
  

 MILITARY END    
31 Select Clocks Week 1 screen: 

Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

TR #0005  

32 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

33 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005  

34 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

35 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

TR #0004  

36 Select Employee>Field from the 
SLDCADA Main Menu. 

The Civilian Tab in the Employee Field is 
displayed. 
 
Note:  This employee is a civilian and 
military, therefore, the civilian tabs were 
bypassed since military is what needed to be 
tested. 
 
Note:  If the user menu class is Self, no 
search windows can be accessed.  The user 
is taken directly to the Military Employee 
Data Maintenance Screen. 
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Event # Action Expected Results  Observations  Requirements  
37 Verify that the Military Tab is selected, 

then select the following: 
Shop:  02 
Sub Shop: 
Rotation Code: 
Rotation Sequence: 
Work Schedule: SS 
Time & Labor:  5 
Supv. Assignment: 01 
Pay Block: 802 
Badge Revision Number: 0 
Union Unit Code: Unit 
Direct/Indirect Code: D 
Army AMS Code: 
Stab Rate Category: 
Temp Supervisor Assignment:  
Employee Activity:  000109 
Full Time/Part Time: F 
Employee Type Code: R 
Pay Plan: ML 
Military Rank: E01 
Funded/Unfunded: F 
Shifts Week 1 & 2: 
Sunday-Saturday 02  

The information appears on the screen. 
 
Note:  This is set up for inquiry only. 
 
 
 
 

Successful Data Inquiry 
(47) 

38 Select the Military Predetermined tab in 
the Military  Employee Field Data 
Maintenance Screen. 

The Military Employee Predetermined Field 
Data Maintenance screen appears. 
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Event # Action Expected Results  Observations  Requirements  
39 Verify that the following are listed in the 

Military  Employee Predetermined Field 
Data Maintenance screen: 
JON:  62R240Y 
Expiration Date:  09/30/2000 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 

The information appears on the screen.   
 

  

40 Select Reports>Cert List-Cert Emp Rpt. A message is displayed stating that there are 
no certified employees for this search name 
Beverly Garland. 

  

41 Select OK. The Military Predetermined Screen is 
displayed. 

  

42 Select Reports>Cert List-UnCert Emp 
Rpt. 

A message is displayed stating that there are 
no uncertified employees for this search 
name Beverly Garland. 

  

43 Select OK. The Military Predetermined Screen is 
displayed. 

  

44 Select Reports>Incorrect Hours. A message is displayed stating that there are 
no incorrect hours for this search. 

  

45 Select OK. The Military Predetermined Screen is 
displayed. 

  

46 Select Reports>Missing Timecards. A message is displayed stating that there are 
no missing timecards for this search. 

  

47 Select OK. The Military Predetermined Screen is 
displayed. 

  

48 Select Reports>Uncertified Employees. A message is displayed stating that there are 
no uncertified employees for this search. 

  

49 Select OK. The Military Predetermined Screen is 
displayed. 
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Event # Action Expected Results  Observations  Requirements  
50 Select the Exit SLDCADA from the 

SLDCADA Main Menu. 
SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

51 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case MILITARY SE/SE INQUIRY ONLY 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 17 4.3.3 Default Password Provide the user the ability to change the default password. P 2 

 18 4.3.3 Submit Password Provides the user the ability to submit the changed  P 2 
 password and continue in SLDCADA. 

 20 4.3.3 Successful Password Provides the ability for the user to know that the password  P 4 
 change was successful. 

 21 4.3.3 Password (Tool Bar) Allows the user to change the password from the tool bar. P 4 

 22 4.3.4 Employee Type Provides the user the ability to choose an employee type for  P 1 
 the session: Civilian, Non-Employee or Military. 

 23 4.3.4 System News Screen Allows the user to view the System News Screen. P 2 

 47 4.5.4 Data Inquiry Provides the ability for users to have read only access and no P 3 
  save option on the screen. 

 77 4.7.1.3 Hz Code (Military) Deny military the use of any environmental hazard codes. P 3 

 80 4.7.1.3 ND Code (Military) Deny Military (employee type = M or B) the use of Night  P 3 
 Differential Code. 
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Joint Interoperability Test Command 
 
 

Software Test Description  
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 hours against job order numbers for financial purposes, and hours against type hour codes for pay purposes.  

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code Self and have access rights only to Self.   
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STD 3-Military SE/SE Update 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: military 
Password: military_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: military 
New Password: military_3 
Confirm New Password: military_3 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 
Note:  The user is logged in as self so only 
the user is displayed, therefore, no search 
options are available. 

  

7 Enter the following information: 
JON: 1212TEST 
P Shop: 03 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

8 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 
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Event # Action Expected Results  Observations  Requirements  
9 Select Time and Attendance Week 1 (11-

11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

10 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

11 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

12 Select OK. A message appears stating that the 
validation and save were successful. 

  

13 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

14 Select the Add icon. A new row is added.   
15 Enter the following information: 

JON: 1212TEST 
P Shop: 03 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

16 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

17 Select MD next to the new row, then 
select Save. 

A message is displa yed stating that you 
have marked records for deletion. 

  

18 Select OK. The record is deleted from the Time and 
Attendance window. 
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Event # Action Expected Results  Observations  Requirements  
19 Select Clocks Week 1 screen: 

Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

TR #0005  

20 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

21 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005  

22 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

23 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

TR #0004  

24 Select Employee>Field from the 
SLDCADA Main Menu. 

The Military Tab is in the Employee Field is 
displayed. 
 
Note:  Only military tabs should be 
displayed. 
 
Note:  If the user menu class is Self, no 
search windows can be accessed.  The user 
is taken directly to the Military Employee 
Data Maintenance Screen. 
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Event # Action Expected Results  Observations  Requirements  
25 Verify that the Military Tab is selected, 

then select the following: 
Shop:  02 
Rotation Code:  
Work Schedule: SS 
Time & Labor:  4 
Supv. Assignment: 1 
Badge Revision Number: 0 
Union Unit Code: Unit 
Direct/Indirect Code: Direct 
Temp Supv. Assignment:  
Employing Activity: 000109-AOC 
Full/Part-Time: Full Time 
Military Rank: 000109-E09 
Funded/Unfunded: Funded 
Shifts Week 1 & 2: 
Sunday-Saturday 0 

The information appears on the screen. 
 
Note:  The following are required fields: 
Employee Name, Shop, Work Schedule, 
Supervisor Assignment and Time and Labor 
Category. 
 
Note: Previous weeks displayed were 
accessed by query only. 

Successful Field Military 
(Query, Enter 
Information, 
Select 
Information) 
(215, 216, 217, 
218) 
 

26 Select the Reference List (?) next to the 
each item. 

The item codes are listed and described. 
 
 

Failed 
 
TR #0007 

Field Military 
(Reference) 
(221)  
 
 

27 Close the Reference List. The reference list closes.   
28 Enter in the following information: 

Sub Shop:  
Rotation Sequence:  
Pay Block:  
Army AMS Code:  
Stab Rate Category:  
Employee Type Code: R 
Pay Plan: ML 

The information appears on the screen.   
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Event # Action Expected Results  Observations  Requirements  
29 Select the Military Predetermined tab in 

the Military  Employee Field Data 
Maintenance Screen. 

The Military Employee Predetermined Field 
Data Maintenance screen appears. 

Successful Field Military  
(Predetermined
) (224) 

30 Enter the following into the Military 
Employee Predetermined Payroll Data 
Maintenance screen: 
JON:  1212TEST 
Expiration Date: 12-31-2001 
Hours:  0 
Labor Class Codes: 
Operation Codes: 
Select the Benefiting Shop: 

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day or the 
work schedule. 
 

Successful Field Military  
(JON, Hours 
Field, Work 
Field, Labor 
Data, 
Expiration, 
Labor Hours, 
Shop, Codes) 
(219, 222, 223, 
225, 227, 228, 
229, 230)  

31 Select the Add icon. A new row is added. Successful Field Military 
(Add) (220) 

32 Enter the following into the Military 
Employee Predetermined Payroll Data 
Maintenance screen: 
JON:  1212TEST 
Expiration Date: 12-31-2001 
Hours:  0 
Labor Class Codes: 
Operation Codes: 
Select the Benefiting Shop: 
 
Select Save. 

The information appears on the screen.   
 
 
 

  

33 Close the Validation screen. The Military Predetermined Screen appears.   
34 Select MD next to the new row, then 

select Save. 
A message is displayed stating that you 
have marked records for deletion. 

Successful Field Military 
(MD) (226) 

35 Select OK. The record is deleted from the Time and 
Attendance window. 

  

Event # Action Expected Results  Observations  Requirements  
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36 Select Reports>Cert List-Cert Emp Rpt. A message is displayed stating that there are 
no certified employees for this search name 
Military Mary. 

  

37 Select OK. The Military Predetermined Screen is 
displayed. 

  

38 Select Reports>Cert List-UnCert Emp 
Rpt. 

A message is displayed stating that there are 
no uncertified employees for this search 
name Military Mary. 

  

39 Select OK. The Military Predetermined Screen is 
displayed. 

  

40 Select Reports>Incorrect Hours. A message is displayed stating that there are 
no incorrect hours for this search. 

  

41 Select OK. The Military Predetermined Screen is 
displayed. 

  

42 Select Reports>Missing Timecards. A message is displayed stating that there are 
no missing timecards for this search. 

  

43 Select OK. The Military Predetermined Screen is 
displayed. 

  

44 Select Reports>Uncertified Employees. A message is displayed stating that there are 
no uncertified employees for this search. 

  

45 Select OK. The Military Predetermined Screen is 
displayed. 

  

46 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

47 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case MILITARY SE/SE UPDATE 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 156 4.9.1.3 Military Allows the user to maintain military employee data.   NT SLDCADA-0013 3 

 157 4.9.1.3 Military (Enter Information) Allows the user to enter the following information in the Military NT SLDCADA-0013 3 
  Employee Data Maintenance Screen:  Pay Block, Army AMS  
 code, Employee Type Code, Pay Plan, Sub Shop and Stab Rate  

 158 4.9.1.3 Military (Select Information) Allows the user to view and select from a pull down menu in the  NT SLDCADA-0013 3 
 Military Employee Data Maintenance Screen:  Shop, Work  
 Schedule, Time and Labor Category, Supervisor Assignment,  
 Badge Revision Number, Union Unit Code, Direct/Indirect Code,  
 Temporary Supervisor Assignment, Employee Activity, Full/Part  
 Time Employee, Military Rank, Funded/Unfunded and daily  

 159 4.9.1.3 Military (Predetermined) Provides the ability to maintain a military employee's  NT SLDCADA-0013 3 
 predetermined labor data. 

 160 4.9.1.3 Military (Labor Data) Allows the user to access the Military Predetermined labor data. NT SLDCADA-0013 3 

 161 4.9.1.3 Military (JON) Provides the ability to enter up to 99 Job Order Numbers for a  NT SLDCADA-0013 3 
 military employee. 

 162 4.9.1.3 Military (Add) Allows the user to add a row and enter the Job Order Numbers for  NT SLDCADA-0013 3 
 each military employee. 

 163 4.9.1.3 Military (Reference) Capability to use the reference list for the military Job Order  NT SLDCADA-0013 4 
 Numbers and display the Job Order Numbers on the labor screens. 

 164 4.9.1.3 Military (Hours Field) Provides the ability to generate military hours according to the  NT SLDCADA-0013 3 
 Hours field per day. 
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SLDCADA Requirements List for Test Case MILITARY SE/SE UPDATE 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 165 4.9.1.3 Military (Work Field) Provides the ability to generate military hours according to the  NT SLDCADA-0013 3 
 work schedule.   

 166 4.9.1.3 Military (MD) Allows the user to delete a military Job Order Number record. NT SLDCADA-0013 3 

 167 4.9.1.3 Military (Expiration) Allows the user to enter the military Job Order Number expiration NT SLDCADA-0013 3 
  date. 

 168 4.9.1.3 Military (Labor Hours) Allows the user to enter the military Job Order Number labor  NT SLDCADA-0013 3 
 hours. 

 169 4.9.1.3 Military (Shop) Allows the user to choose the military Job Order Number's  NT SLDCADA-0013 3 
 benefiting shop. 

 170 4.9.1.3 Military (Codes) Allows the user to enter the military Labor Class and Operation  NT SLDCADA-0013 3 
 Codes. 

 215 4.9.2.3 Field Military Allows the user to maintain military employee data.   P 3 

 216 4.9.2.3 Field Military (Query) Provides the ability to access all data displayed for previous  P 3 
 weeks by query only. 

 217 4.9.2.3 Field Military (Enter  Allows the user to enter the following information in the Military P 3 
 Information)  Employee Data Maintenance Screen:  Pay Block, Army AMS  
 code, Employee Type Code, Pay Plan, Sub Shop and Stab Rate  
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SLDCADA Requirements List for Test Case MILITARY SE/SE UPDATE 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 218 4.9.2.3 Field Military (Select  Allows the user to view and select from a pull down menu in the  P 3 
 Information) Military Employee Data Maintenance Screen:  Shop, Work  
 Schedule, Time and Labor Category, Supervisor Assignment,  
 Badge Revision Number, Union Unit Code, Direct/Indirect Code,  
 Temporary Supervisor Assignment, Employee Activity, Full/Part  
 Time Employee, Military Rank and Funded/Unfunded. 

 219 4.9.2.3 Field Military (JON) Provides the ability to enter up to 99 Job Order Numbers for a  P 3 
 military employee. 

 220 4.9.2.3 Field Military (Add) Allows the user to add a row and enter the Job Order Numbers for  P 3 
 each military employee. 

 221 4.9.2.3 Field Military (Reference) Capability to use the reference list for the military Job Order  F SLDCADA-0007 4 
 Numbers and display the Job Order Numbers on the labor screens. 

 222 4.9.2.3 Field Military (Hours Field) Provides the ability to generate military hours according to the  P 3 
 Hours field per day. 

 223 4.9.2.3 Field Military (Work Field) Provides the ability to generate military hours according to the  P 3 
 work schedule.   

 224 4.9.2.3 Field Military (Predetermined) Provides the ability to maintain a military employee's  P 3 
 predetermined labor data. 

 225 4.9.2.3 Field Military (Labor Data) Allows the user to access the Military Predetermined labor data. P 3 

 226 4.9.2.3 Field Military (MD) Allows the user to delete a military Job Order Number record. P 3 
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SLDCADA Requirements List for Test Case MILITARY SE/SE UPDATE 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 227 4.9.2.3 Field Military (Expiration) Allows the user to enter the military Job Order Number expiration P 3 
  date. 

 228 4.9.2.3 Field Military (Labor Hours) Allows the user to enter the military Job Order Number labor  P 3 
 hours. 

 229 4.9.2.3 Field Military (Shop) Allows the user to choose the military Job Order Number's  P 3 
 benefiting shop. 

 230 4.9.2.3 Field Military (Codes) Allows the user to enter the military Labor Class and Operation  P 3 
 Codes. 
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1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian, military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type hour 
codes for pay purposes.  

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code Supervisor and have access rights only to the Supervisor Assignment Group.   
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STD 4- Non-Employee SU/SG 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: stanemp 
Password: stanemp_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: stanemp 
New Password: stanemp_3 
Confirm New Password: stanemp_3 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Search Window appears. 
 
Note: Searches can be performed using the 
Employee Name, SSN, Shop or Supervisor 
Assignment. 

  

7 Select the desired week ending date: 11-
12-00/11-18-00. 

The week ending date appears in the dialog 
box. 

  

8 Verify that the Supervisor Assignment is 
highlighted in the Search Criteria box, 
then enter the supervisor assignment 
(ALL) into the Search Criteria Value box, 
then select Search. 

All of the supervisor assignments are 
displayed in the Time and Attendance Data 
Screen. 
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Event # Action Expected Results  Observations  Requirements  
9 Select Micky Mouse from the list of 

employees in the Time and Attendance 
Data Screen. 

Micky Mouse is highlighted.   

10 Select Time and Attendance Week 2 (11-
18-00).  Enter in the following: 
P Shop: 03 
TYHR: RG 
Select Save. 

Validation screen is displayed. 
 
Note:  If there is no JON predetermined, 
none will be displayed in the JON pull 
down. 

  

11 Close the validation screen. The Week 2 Time and Attendance Data 
Screen is displayed. 

  

12 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday, then select Time and 
Attendance Week 2 (11-18-00).  Select 
Save. 

A message is displayed asking if the 
changes should be saved. 

  

13 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

14 Close the error message.  Change the 
hours to 8 for Thursday in Week 1 and 
then select the Week 2 Time and 
Attendance window.  

A message is displayed asking if the 
changes should be saved. 

  

15 Select OK. A message appears stating that the 
validation and save were successful. 

  

16 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

17 Select Clocks Week 1 screen: 
Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

TR #0005  

Event # Action Expected Results  Observations  Requirements  
18 Close the validation message. The Week 1 Time and Attendance Data 

Screen appears. 
  



 

C-1 

19 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005  

20 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

21 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

TR #0004  

NOTE: Non-Employees will not show up in the certification screen.   
22 Select Employee>Payroll from the 

SLDCADA Main Menu. 
The Employee Search Screen is displayed. 
 
Note: Only Employee Name and SSN are 
available for the search criteria. 
 

  

23 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

24 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Micky 
Mouse) into the Search Criteria Value 
box, then select Search. 

Micky Mouse’s information is displayed in 
the Non-Employee Payroll Data 
Maintenance Screen. 
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Event # Action Expected Results  Observations  Requirements  
25 Verify that the Non-employee Tab is 

selected, then select the following: 
Shop:  03 
Rotation Code: 
Work Schedule: 01 
Time & Labor:  1 
Supv. Assignment: 01 
Temp Supv. Assignment: 01R 
Employing Activity: 000024-NAVSEA 
Shifts Week 1: Sunday 3, Monday-
Saturday 1 
Shifts Week 2: Sunday-Saturday 1 

The information appears on the screen. 
 
Note:  The following are required fields: 
Employee Name, Shop, Work Schedule, 
Supervisor Assignment and Time and Labor 
Category. 
 
Note:  The employee is a non-employee and 
military, therefore non-employee was tested 
here. 

Successful Non-employee 
(Enter 
Information) 
(171, 172) 

26 Select the Reference List (?) next to the 
each item. 

The item codes are listed and described. Failed 
 
TR #0007 

Non-Employee 
(Reference) 
(178) 
 
 

27 Close the Reference List. The reference list closes.   
28 Enter in the following information: 

Sub Shop: 
Rotation Sequence: 
Onboard Date: 12-22-00 
NTE Date: 12-22-01 
Host Company: GETRONICS 
Local POC: Mouse, Minnie  

The information appears on the screen. Successful Non-employee 
(Select 
Information) 
(173) 

29 Select the Non-employee Predetermined 
tab in the Non-employee Payroll Data 
Maintenance Screen. 

The Non-employee Employee 
Predetermined Payroll Data Maintenance 
screen appears. 
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Event # Action Expected Results  Observations  Requirements  
30 Enter the following into the Non-

employee Predetermined Payroll Data 
Maintenance screen: 
JON:  
Expiration Date: 
Hours: 0 
Labor Class Codes: 
Operation Codes: 
Select the Benefiting Shop: 01 
 
Select Save. 

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day or work 
schedule. 
 
Note: As many as 99 JONs may be entered 
into this screen. 

Successful Non-employee 
(Predetermined
, Labor Data, 
JON, Hours 
Field, Work 
Schedule, 
Expiration, 
Labor Hours, 
Shop, Codes) 
(174, 175, 176, 
179, 180, 182, 
183, 184, 185) 

31 Select the Add icon on the tool bar. A new row is added and loaded with any 
default values.   

Successful Non-employee 
(Add) (177) 

32 Enter the following into the Non-
employee Predetermined Payroll Data 
Maintenance screen: 
JON:  
Expiration Date: 
Hours: 0 
Labor Class Codes: 
Operation Codes: 
Select the Benefiting Shop: 01 
 
Select Save. 

The information appears on the screen.   
 

  

33 Select the box labeled MD next to the just 
added row. 

A check appears in the MD box. Successful Non-employee 
(MD) (181) 

34 Select the save button. A message appears stating that records are 
marked for deletion. 

  

35 Select OK from the message. The record is deleted from the Non-
Employee Predetermined Screen. 

  

36 Select Reports>Cert List-Cert Emp Rpt. The Search Screen is displayed.   
Event # Action Expected Results  Observations  Requirements  

37 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 
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38 Verify that the Employee Activity is 
highlighted in the Search Criteria box, 
then enter Employee Activity (000024) 
into the Search Criteria Value box, then 
select Search. 

A message is displayed stating that there are 
no certified employees found for the search 
000024. 

Successful Employing 
Activity 
(Search, 
Conduct) (66, 
67, 68) 

39 Close the Certified Employees Report 
Screen. 

The screen closes to the Non-Employee 
Predetermined Screen. 

  

40 Select Reports>Cert List-UnCert Emp 
Rpt. 

The Search Screen is displayed.   

41 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

42 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Micky 
Mouse) into the Search Criteria Value 
box, then select Search. 

A message is displayed stating that there are 
no uncertified employees found for the 
search Micky Mouse. 
 

  

43 Close the Uncertified Employees Report 
Screen. 

The screen closes to the Non-Employee 
Predetermined Screen. 

  

44 Select Reports>Incorrect Hours. The Search Screen is displayed. 
 
 

  

45 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

46 Verify that the Shop is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

The Incorrect Hours Report appears 
displaying employees whose daily hours do 
not match their work schedule. 
 

  

47 Close the Incorrect Hours Report. The screen closes to the Non-Employee 
Predetermined Screen. 

  

48 Select Reports>Uncertified Employees. The Search Screen appears.   
Event # Action Expected Results  Observations  Requirements  

49 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 
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50 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter Micky Mouse into the Search 
Criteria Value box, then select Search. 

A message is displayed stating that there are 
no uncertified employees found for the 
search Micky Mouse. 
 

  

51 Close the Uncertified Employees Report. The screen closes to the Non-Employee 
Predetermined Screen. 

  

52 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

53 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case NON-EMPLOYEE SU/SG 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 66 4.6.6 Employing Activity Provide the ability to use Employing Activity as a search criteria. P 3 

 67 4.6.6 Employing Activity (Search) Provide the ability to select a Employing Activity as a search  P 3 
 criteria value. 

 68 4.6.6 Employing Activity  Provide the user the ability to conduct a search by using the  P 3 
 Employing Activity. 

 171 4.9.1.4 Non-Employee Allows the user to maintain Non-Employee data.   P 3 

 172 4.9.1.4 Non-Employee (Enter  Allows the user to enter the following information in the  P 3 
 Information) Non-Employee Data Maintenance Screen:  On Board Date, NTE  
 Date, Host Company, Sub Shop and Local POC. 

 173 4.9.1.4 Non-Employee (Select  Allows the user to view and select from a pull down menu in the  P 3 
 Information) Non-Employee Data Maintenance Screen:  Shop, Work Schedule,  
 Time and Labor Category, Supervisor Assignment, Temporary  
 Supervisor Assignment and Employee Activity. 

 174 4.9.1.4 Non-Employee  Provides the ability to maintain a Non-Employee's predetermined P 3 
  labor data. 

 175 4.9.1.4 Non-Employee (Labor Data) Allows the user to access the Non-Employee Predetermined labor P 3 
  data. 

 176 4.9.1.4 Non-Employee (JON) Provides the ability to enter up to 99 Job Order Numbers for a  P 3 
 Non-Employee. 
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SLDCADA Requirements List for Test Case NON-EMPLOYEE SU/SG 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 177 4.9.1.4 Non-Employee (Add) Allows the user to add a row and enter the Job Order Numbers for  P 3 
 each Non-Employee. 

 178 4.9.1.4 Non-Employee (Reference) Capability to use the reference list for the Non-Employee Job  F SLDCADA-0007 4 
 Order Numbers and display the Job Order Numbers on the labor  
 screens. 

 179 4.9.1.4 Non-Employee (Hours Field) Provides the ability to generate Non-Employee hours according  P 3 
 to the Hours field per day. 

 180 4.9.1.4 Non-Employee (Work Field) Provides the ability to generate Non-Employee hours according  P 3 
 to the work schedule.   

 181 4.9.1.4 Non-Employee (MD) Allows the user to delete a Non-Employee Job Order Number  P 3 
 record. 

 182 4.9.1.4 Non-Employee (Expiration) Allows the user to enter the Non-Employee Job Order Number  P 3 
 expiration date. 

 183 4.9.1.4 Non-Employee (Labor Hours) Allows the user to enter the Non-Employee Job Order Number  P 3 
 labor hours. 

 184 4.9.1.4 Non-Employee (Shop) Allows the user to choose the Non-Employee Job Order Number's P 3 
  benefiting shop. 

 185 4.9.1.4 Non-Employee (Codes) Allows the user to enter the Non-Employee Labor Class and  P 3 
 Operation Codes. 

 231 4.9.2.4 Field Non-Employee Allows the user to maintain Non-Employee data.   NT SLDCADA-0013 3 
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SLDCADA Requirements List for Test Case NON-EMPLOYEE SU/SG 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 232 4.9.2.4 Field Non-Employee (Query) Provides the ability to access all data displayed for previous  NT SLDCADA-0013 3 
 weeks by query only. 

 233 4.9.2.4 Field Non-Employee (Enter  Allows the user to enter the following information in the  NT SLDCADA-0013 3 
 Information) Non-Employee Data Maintenance Screen:  On Board Date, NTE  
 Date, Host Company, Sub Shop and Local POC. 

 234 4.9.2.4 Field Non-Employee (Select  Allows the user to view and select from a pull down menu in the  NT SLDCADA-0013 3 
 Information) Non-Employee Data Maintenance Screen:  Shop, Work Schedule,  
 Time and Labor Category, Supervisor Assignment, Temporary  
 Supervisor Assignment and Employee Activity. 

 235 4.9.2.4 Field Non-Employee (JON) Provides the ability to enter up to 99 Job Order Numbers for a  NT SLDCADA-0013 3 
 Non-Employee. 

 236 4.9.2.4 Field Non-Employee (Add) Allows the user to add a row and enter the Job Order Numbers for  NT SLDCADA-0013 3 
 each Non-Employee. 

 237 4.9.2.4 Field Non-Employee  Capability to use the reference list for the Non-Employee Job  NT SLDCADA-0013 4 
 (Reference) Order Numbers and display the Job Order Numbers on the labor  
 screens. 

 238 4.9.2.4 Field Non-Employee (Hours  Provides  the ability to generate Non-Employee hours according  NT SLDCADA-0013 3 
 Field) to the Hours field per day. 

 239 4.9.2.4 Field Non-Employee (Work  Provides the ability to generate Non-Employee hours according  NT SLDCADA-0013 3 
 Field) to the work schedule.   
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SLDCADA Requirements List for Test Case NON-EMPLOYEE SU/SG 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 240 4.9.2.4 Field Non-Employee  Provides the ability to maintain a Non-Employee's predetermined NT SLDCADA-0013 3 
 (Predetermined)  labor data. 

 241 4.9.2.4 Field Non-Employee (Labor  Allows the user to access the Non-Employee Predetermined labor NT SLDCADA-0013 3 
 Data)  data. 

 242 4.9.2.4 Field Non-Employee (MD) Allows the user to delete a Non-Employee Job Order Number  NT SLDCADA-0013 3 
 record. 

 243 4.9.2.4 Field Non-Employee  Allows the user to enter the Non-Employee Job Order Number  NT SLDCADA-0013 3 
 (Expiration) expiration date. 

 244 4.9.2.4 Field Non-Employee (Labor  Allows the user to enter the Non-Employee Job Order Number  NT SLDCADA-0013 3 
 Hours) labor hours. 

 245 4.9.2.4 Field Non-Employee (Shop) Allows the user to choose the Non-Employee Job Order Number's NT SLDCADA-0013 3 
  benefiting shop. 

 246 4.9.2.4 Field Non-Employee (Codes) Allows the user to enter the Non-Employee Labor Class and  NT SLDCADA-0013 3 
 Operation Codes. 
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1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian , military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type 
hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code Timekeeper and have access rights only to those in the User’s Shop.    
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STD 5-Civilian TK/CC 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: ungraded 
Password: ungraded_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: ungraded 
New Password: ungraded_2 
Confirm New Password: ungraded_2 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 

  

7 Select the desired week ending date: 11-
12-00/11-18-00. 

The week ending date appears in the dialog 
box. 

  

8 Verify that the Shop is highlighted in the 
Search Criteria box, then enter the Shop 
(02) into the Search Criteria Value box, 
then select Search. 

All of the people are displayed in the Time 
and Attendance Data Screen. 
 
Note: Only the shop that TK/CC user is 
assigned to is displayed. 

  

9 Select Una Ungraded from the list. Una Ungraded is highlighted.   
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Event # Action Expected Results  Observations  Requirements  
10 Enter the following information: 

JON: 1212TEST 
P Shop: 03 
TYHR: RG (Default) 
 
Select Save. 

A message is displayed stating that there is 
a minor error:  An ungraded employee 
cannot have a graded TYHR Code. 
 
 

TR #0008  

11 Close the error screen. The Week 2 Time and Attendance Screen is 
displayed. 

  

12 Change the TYHR Code to RF, then 
select Save. 

The validation screen is displayed.   

13 Close the validation screen. The Week 2 Time and Attendance screen is 
displayed. 

  

14 Select Time and Attendance Week 1 and 
enter the following: 
P Shop: 03 
TYHR: RF 
 
Select Save. 

The validation screen is displayed.   

15 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 

  

16 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

17 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

18 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 
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Event # Action Expected Results  Observations  Requirements  
19 Select OK. A message appears stating that the 

validation and save were successful. 
  

20 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

 UNGRADED BEGINS    
21 Enter in the following: 

Hazard Code: spaces 
ND: ND 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded cannot use Night 
Differential Code. 

Successful ND Code 
(Ungraded) 
(82) 

22 Close the error screen. The Week 1 Time and Attendance Screen is 
displayed. 

  

23 Enter in the following: 
TYHR: HG 
Then click on the Save icon. 

The following error message will be 
displayed: Graded type hour codes cannot 
be used for Ungraded employees. 
 
Note:  The user can still save the 
information since it is a minor error. 

Successful TYHR 
(Ungraded) 
(89) 

24 Close the error screen. The Week 1 Time and Attendance Screen is 
displayed. 

  

25 Enter in the following: 
TYHR: RG 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded cannot use Night 
Differential Code. 
 

  

26 Close the error screen. The Week 1 Time and Attendance Screen is 
displayed. 

  

27 Enter in the following: 
TYHR: SG 
Then click on the Save icon. 

The following error message will be 
displayed: Ungraded cannot use Night 
Differential Code. 

  

28 Close the error screen. The Week 1 Time and Attendance Screen is 
displayed. 

  

 UNGRADED ENDS    
29 Select the Add icon. A new row is added.   

Event # Action Expected Results  Observations  Requirements  



 

C-1 

30 Enter the following information: 
JON: 1212TEST 
P Shop: 03 
TYHR: RF 
 
Select Save. 

The validation screen is displayed.   

31 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

32 Select MD next to the new row, then 
select Save. 

A message is displayed stating that you 
have marked records for deletion. 

  

33 Select OK. The record is deleted from the Time and 
Attendance window. 

  

34 Select Clocks Week 1 screen: 
Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

TR #0005  

35 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

36 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 

TR #0005  

37 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

38 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 

TR #0004  

39 Select Employee>Field from the 
SLDCADA Main Menu. 

The Search Screen is displayed.   

Event # Action Expected Results  Observations  Requirements  
40 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 
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41 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Una 
Ungraded) into the Search Criteria Value 
box, then select Search. 

Una Ungraded’s information is displayed in 
the Civilian Employee Field Data 
Maintenance Screen. 
 

  

42 Verify that the Civilian Tab is sele cted, 
then select the following: 
Shop:  02 
Rotation Code: 
Work Schedule: SS 
Time & Labor:  3 
Supv. Assignment: 01 
Environmental Hazard:  
Shifts Week 1 & 2:  
Sunday-Saturday 00 

The information appears on the screen. 
 
 
 
 

  

43 Select the Reference List (?) next to the 
items. 

The item codes are listed and described. TR #0007  

44 Close the Reference List. The reference list closes.   
45 Enter in the following information: 

Subshop:  
Rotation Sequence: 
Injury Dates:  

The information appears on the screen. 
 
Note : Previous weeks displayed were 
accessed by query only. 

  

46 Select the Civilian Predetermined tab in 
the Civilian Employee Field Data 
Maintenance Screen. 

The Civilian Employee Predetermined Field 
Data Maintenance screen appears. 
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Event # Action Expected Results  Observations  Requirements  
47 Enter the following into the Civilian 

Employee Predetermined Field Data 
Maintenance screen: 
JON:  1212TEST 
Expiration Date:  12/31/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop:  

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day. 

  

48 Select the Add icon on the tool bar. A new row is added and loaded with any 
default values.   

  

49 Enter the following into the new row: 
JON:  1212 TEST 
Expiration Date:  12/31/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 02 
 
Select Save. 

The information appears in the row.   
 

  

50 Close the Validation screen. The Civilian Predetermined Screen is 
displayed. 

  

51 Select the box labeled MD next to the just 
added row. 

A check appears in the MD box.   

52 Select the save button. A message appears stating that records are 
marked for deletion. 
 

  

53 Select OK. The Civilian Predetermined Screen appears.   
54 Select the Leave Availability Tab. The Leave Availability for the employee is 

displayed. 
 
Note:  This screen can only be viewed. 

  

Event # Action Expected Results  Observations  Requirements  
55 Select Reports>Cert List-Cert Emp Rpt. The Search Screen is displayed.   
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56 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

57 Verify that the Employee Activity is 
highlighted in the Search Criteria box, 
then enter Employee Activity (000024) 
into the Search Criteria Value box, then 
select Search. 

A message is displayed stating that there are 
no certified employees found for the search 
000024. 

  

58 Close the Certified Employees Report 
Screen. 

The screen closes to the Leave Availabilty 
Screen. 

  

59 Select Reports>Cert List-UnCert Emp 
Rpt. 

The Search Screen is displayed.   

60 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

61 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Una 
Ungraded) into the Search Criteria Value 
box, then select Search. 

A message is displayed stating that there are 
no uncertified employees found for the 
search Una Ungraded. 
 

  

62 Close the Uncertified Employees Report 
Screen. 

The screen closes to the Leave Availabilty 
Screen. 

  

63 Select Reports>Incorrect Hours. The Search Screen is displayed. 
 
 

  

64 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

65 Verify that the Shop is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

The Incorrect Hours Report appears 
displaying employees whose daily hours do 
not match their work schedule. 

  

66 Close the Incorrect Hours Report. The screen closes to the Leave Availabilty 
Screen. 

  

Event # Action Expected Results  Observations  Requirements  
67 Select Reports>Uncertified Employees. The Search Screen appears.   
68 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 
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69 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter Una Ungraded into the Search 
Criteria Value box, then select Search. 

A message is displayed stating that there are 
no uncertified employees found for the 
search Una Ungraded. 
 

  

70 Close the Uncertified Employees Report. The screen closes to the Leave Availabilty 
Screen. 

  

71 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

72 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case CIVILIAN TK/CC 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 82 4.7.1.3 ND Code (Ungraded) Deny Ungraded (Graded/Ungraded code = U) the use of  P 3 
 Night Differential Code. 

 89 4.7.1.3 TYHR (Ungraded) Deny Ungraded Type Hour Codes HF, HS, HT, RF, RS, RT,  P 3 
 SF, SS, or ST to be used for graded employees. 
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1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian , military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type 
hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code Timekeeper and have access rights only to those in the User’s Shop and all those Cross-Referenced to the User’s 
Shop.    
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STD 6-Civilian TK/XC 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: freddy 
Password: freddy_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: freddy 
New Password: fredy_2 
Confirm New Password: fredy_2 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 

  

7 Select the desired week ending date: 11-
12-00/11-18-00. 

The week ending date appears in the dialog 
box. 

  

8 Verify that the Shop is highlighted in the 
Search Criteria box, then enter the Shop 
(02) into the Search Criteria Value box, 
then select Search. 

All of the people in the Shop are displayed 
in the Time and Attendance Data Screen. 
 
Note: Only the shops that TK/XC user are 
assigned to is displayed. 

  

9 Select Freddy Firefighter from the list. Freddy Firefighter is highlighted.   
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Event # Action Expected Results  Observations  Requirements  
10 Enter the following information: 

JON: Fire1 
P Shop: 03 
TYHR: RG  
 
Select Save. 

The validation screen is displayed. 
 
 

  

11 Close the validation screen. The Week 2 Time and Attendance screen is 
displayed. 

  

12 Select Time and Attendance Week 1 and 
enter the following: 
JON: Fire1 
P Shop: 03 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

13 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 

  

14 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

15 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

16 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

17 Select OK. A message appears stating that the 
validation and save were successful. 

  

18 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

Event # Action Expected Results  Observations  Requirements  
 FIREFIGHTER BEGINS    



 

C-1 

19 Enter in the following: 
Hazard Code: EA 
ND: spaces 
Then click on the Save icon. 
 

The following error message will be 
displayed: Military, SES, and Firefighters 
cannot use Environmental Code. 

  

20 Close the error message. The Time and Attendance Week 1 Screen is 
displayed. 

  

21 Enter in the following: 
Hazard Code: DA 
ND: spaces 
Then click on the Save icon. 

An error message is displayed stating that 
the EHz cannot be used with the TYHR. 

  

22 Close the error message. The Time and Attendance Week 1 Screen is 
displayed. 

  

23 Enter in the following: 
Hazard Code: spaces 
ND: ND 
Then click on the Save icon. 

The following error message will be 
displayed: Firefighters and SES (employee 
type = B or F) cannot use Night Differential 
Code. 
 
 

TR #0009  

24 Close the error message. The Time and Attendance Week 1 Screen is 
displayed. 

  

25 Enter in the following: 
TYHR: OS 
Then click on the Save icon. 

The following error message will be 
displayed: Firefighters (employee type = F) 
cannot use OS type hour code. 

Successful TYHR 
(Firefighter) 
(87) 

26 Close the error message. The Time and Attendance Week 1 Screen is 
displayed. 

  

27 Enter in the following: 
HZ:  BA 
TYHR: LU 
Then click on the Save icon. 

A message appears stating that you have 
selected LU and all hours will be reset to 0. 

Failed 
 
TR #0010  

TYHR (Injury 
Date, LU) (92, 
93) 

28 Select OK. The hours are all changed to 0.   
Event # Action Expected Results  Observations  Requirements  

29 Select Save. An error message appears stating that the 
user must assign an injury date. 
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30 Enter in the following: 
HZ: B* 
TYHR: LT 
Then click on the Save icon. 

The screen will inquire for an injury date. 
 
 
 

TR #0010  

 FIREFIGHTER ENDS    
31 Select the Add icon. A new row is added.   
32 Enter the following information: 

JON: Fire1 
P Shop: 03 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

33 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

34 Select MD next to the new row, then 
select Save. 

A message is displayed stating that you 
have marked records for deletion. 

  

35 Select OK. The record is deleted from the Time and 
Attendance window. 

  

36 Select Clocks Week 1 screen: 
Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 

TR #0005  

37 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
38 Enter in Clocks Week 2 Screen: 

Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005  

39 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

40 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

TR #0004  

41 Select Employee>Field from the 
SLDCADA Main Menu. 

The Search Screen is displayed.   

42 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

43 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Freddy 
Firefighter) into the Search Criteria Value 
box, then select Search. 

Freddy Firefighter information is displayed 
in the Civilian Employee Field Data 
Maintenance Screen. 
 

  

44 Verify that the Civilian Tab is selected, 
then select the following: 
Shop:  02 
Rotation Code: 
Work Schedule: F1 
Time & Labor:  4 
Supv. Assignment: 1 
Environmental Hazard:  
Shifts Week 1 & 2:  
Sunday-Saturday 00 

The information appears on the screen. 
 
 
 
 

  

45 Select the Reference List (?) next to the 
items. 

The item codes are listed and described. TR #0007  

Event # Action Expected Results  Observations  Requirements  
46 Close the Reference List. The reference list closes.   
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47 Enter in the following information: 
Subshop:  
Rotation Sequence: 
Injury Dates: 

The information appears on the screen. 
 
Note: Previous weeks displayed were 
accessed by query only. 

  

48 Select the Civilian Predetermined tab in 
the Civilian Employee Field Data 
Maintenance Screen. 

The Civilian Employee Predetermined Field 
Data Maintenance screen appears. 

  

49 Enter the following into the Civilian 
Employee Predetermined Field Data 
Maintenance screen: 
JON:  Helpme2 
Expiration Date:  01/06/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop:  

The information appears on the screen.   
 
Note:  The batch process generates hours 
according to the hours field per day. 

  

50 Select the Add icon on the tool bar. A new row is added and loaded with any 
default values.   

  

51 Enter the following into the new row: 
JON:  Helpme2 
Expiration Date:  01/06/2002 
Hours: 0 
Labor Class Codes:  
Operation Codes:  
Select the Benefiting Shop: 02 
 
Select Save. 

The information appears in the row.   
 

  

52 Close the Validation screen. The Civilian Predetermined Screen is 
displayed. 

  

53 Select the box labeled MD next to the just 
added row. 

A check appears in the MD box.   

Event # Action Expected Results  Observations  Requirements  
54 Select the save button. A message appears stating that records are 

marked for deletion. 
  

55 Select OK. The Civilian Predetermined Screen appears.   
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56 Select the Leave Availability Tab. The Leave Availability for the employee is 
displayed. 
 
Note:  This screen can only be viewed. 

  

57 Select Reports>Cert List-Cert Emp Rpt. The Search Screen is displayed.   
58 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 

  

59 Verify that the Employee Activity is 
highlighted in the Search Criteria box, 
then enter Employee Activity (000024) 
into the Search Criteria Value box, then 
select Search. 

The employee activity 000024 is displayed 
on the Certified Employees Report Screen. 

  

60 Close the Certified Employees Report 
Screen. 

The screen closes to the Leave Availabilty 
Screen. 

  

61 Select Reports>Cert List-UnCert Emp 
Rpt. 

The Search Screen is displayed.   

62 Select the desired week ending date: 11-
18-00. 

The week ending date appears in the dialog 
box. 

  

63 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee’s name (Freddy 
Firefighter) into the Search Criteria Value 
box, then select Search. 

Freddy Firefighter is displayed in the 
Certification Listing for Manually Certified 
Employees. 
 

  

64 Close the Uncertified Employees Report 
Screen. 

The screen closes to the Leave Availabilty 
Screen. 

  

65 Select Reports>Incorrect Hours. The Search Screen is displayed. 
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Event # Action Expected Results  Observations  Requirements  
66 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 

  

67 Verify that the Shop is highlighted in the 
Search Criteria box, then enter ALL into 
the Search Criteria Value box, then select 
Search. 

The Incorrect Hours Report appears 
displaying employees whose daily hours do 
not match their work schedule. 

  

68 Close the Incorrect Hours Report. The screen closes to the Leave Availabilty 
Screen. 

  

69 Select Reports>Uncertified Employees. The Search Screen appears.   
70 Select the desired week ending date: 11-

18-00. 
The week ending date appears in the dialog 
box. 

  

71 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter Freddy Firefighter into the 
Search Criteria Value box, then select 
Search. 

Freddy Firefighter is displayed in the 
Uncertified Employees Report.   
 
 

  

72 Close the Uncertified Employees Report. The screen closes to the Leave Availabilty 
Screen. 

  

73 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

74 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case CIVILIAN TK/XC 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 87 4.7.1.3 TYHR (Firefighter) Deny Firefighters (Employee type = F) the use of OS (Overtime  P 3 
 scheduled) Type Hour Code. 

 92 4.7.1.3 TYHR (Injury Date) Ensure Injury Date becomes a mandatory field when Type Hour  F SLDCADA-0010 3 
 Code = LT or LU. 

 93 4.7.1.3 TYHR (LU) Capability to establish an injury date using Type Hour Code LU. F SLDCADA-0010 3 
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For the 
 
 

NAVAL SEA LOGISTIC CENTER (NAVSEA) 
 
 

STANDARD LABOR DATA COLLECTION AND DISTRIBUTION APPLICATION 
(SLDCADA) 

 
 

STD 7-CIVILIAN SES SA/AL 
 
 

May 29, 2001 
 
 
1.   Details of Test Case: STD 7-Civilian SES SA/AL 
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1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian , military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type 
hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code SLDCADA Administrator and have access rights to All.   
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STD 7-Civilian SES SA/AL 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: sammy 
Password: sammy_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: sammy 
New Password: samy_1 
Confirm New Password: samy_1 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 

  

7 Select the desired week ending date: 11-
12-00/11-18-00. 

The week ending date appears in the dialog 
box. 

  

8 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee name (Samantha 
SES) into the Search Criteria Value box, 
then select Search. 

All of the Samantha SES is displayed in the 
Time and Attendance Data Screen. 
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Event # Action Expected Results  Observations  Requirements  
9 Enter the following information: 

JON: 1212SES 
P Shop: 02 
TYHR: RG  
 
Select Save. 

The validation screen is displayed. 
 
 

  

10 Close the validation screen. The Week 2 Time and Attendance screen is 
displayed. 

  

11 Select Time and Attendance Week 1 and 
enter the following: 
JON: 1212SES 
P Shop: 02 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

12 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 

  

13 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 10 for 
Wednesday.  Then select the Time and 
Attendance Week 2 (11-18-00). 

A message is displayed asking if the user 
wants to save changes. 

  

14 Select OK. Error message is displayed stating that time 
was exceeded for Wednesday. 

  

15 Close the error message.  Select Time and 
Attendance Week 1 (11-11-00) and 
change the hours to 8 for Thursday. Then 
select the Time and Attendance Week 2 
(11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

16 Select OK. A message appears stating that the 
validation and save were successful. 

  

17 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

Event # Action Expected Results  Observations  Requirements  
 SES BEGINS    



 

C-1 

18 Enter in the following: 
Hazard Code: EA 
ND: spaces 
Then click on the Save icon. 

The following error message will be 
displayed: Military, SES, and Firefighters 
cannot use Environmental Code. 

  

19 Close the error message. The Time and Attendance Week 1 Screen is 
displayed. 

  

20 Enter in the following: 
Hazard Code: BA 
ND: spaces 
Then click on the Save icon. 

The data is changed and accepted. 
 
 

Failed 
 
TR #0011 

Hz Code (B*, 
D*) (79) 
 
 

21 Close the validation message. The Time and Attendance Week 1 Screen is 
displayed. 

  

22 Enter in the following: 
Hazard Code: spaces 
ND: ND 
Then click on the Save icon. 

The following error message will be 
displayed: Firefighters and SES (employee 
type = B or F) cannot use Night Differential 
Code. 
 
 

Successful 
 
TR #0009 
(This does not 
affect any 
req.) 

ND Code 
(SES) (81) 
 
 

23 Close the validation message. The Time and Attendance Week 1 Screen is 
displayed. 

  

 SES ENDS    
24 Select the Add icon. A new row is added.   
25 Enter the following information: 

JON: 1212SES 
P Shop: 02 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

26 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 
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Event # Action Expected Results  Observations  Requirements  
27 Select MD next to the new row, then 

select Save. 
A message is displayed stating that you 
have marked records for deletion. 

  

28 Select OK. The record is deleted from the Time and 
Attendance window. 

  

29 Select Clocks Week 1 screen: 
Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in the ir hours for the days they 
work. 
 
 

TR #0005  

30 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

31 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005  

32 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

33 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 

TR #0004  

34 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

35 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case CIVILIAN SES SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 79 4.7.1.3 Hz Code (B*, D*) Capability to allow SES and firefighters to use only B* or D*  F SLDCADA-0011 3 
 codes. 

 81 4.7.1.3 ND Code (SES) Deny Firefighters and SES (employee type = B or F) the use of  P 3 
 Night Differential Code. 
 
 



 

C-1 

 

Joint Interoperability Test Command 
 
 

Software Test Description  
 
 
 

For the 
 
 

NAVAL SEA LOGISTIC CENTER (NAVSEA) 
 
 

STANDARD LABOR DATA COLLECTION AND DISTRIBUTION APPLICATION 
(SLDCADA) 

 
 

STD 8-CIVILIAN INTERMITTENT SA/AL 
 
 

May 29, 2001 
 
 
1.   Details of Test Case: STD 8-Civilian Intermittent SA/AL 
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1.1   Title: Standard Labor Data Collection and Distribution Application (SLDCADA) 
 
 
1.2 Description:  The Standard Labor Data Collection and Distribution Application (SLDCADA) is a Naval Sea System Command 

(NAVSEA) developed Time and Attendance System that has recently been chosen as the Department of Navy standard.  
 

The SLDCADA is a timekeeping system that allows for centralized or distributed input, providing the capability to track 
civilian , military, as well as contractor labor hours against job order numbers for financial purposes, and hours against type 
hour codes for pay purposes. 

 
 
1.3 Assumptions and Constraints: SLDCADA website has been successfully accessed.  The user must be logged in using the 

menu code SLDCADA Administrator and have access rights to All.     
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STD 8-Civilian Intermittent SA/AL 

Objective :  To assure that SLDCADA functionality’s are successfully demonstrated and evaluated.  
Requirements:  see attached listing 
Event # Action Expected Results  Observations  Requirements  

1 Open Internet Explorer and type in the 
URL address. 

The Security Alert window is displayed.   

2 Select Yes.  The Login Screen is displayed.   
3 Type the following: 

User ID: ingrid 
Password: ingrid_1 
Then select Login. 

The Password Change Utility Screen 
appears. 

  

4 Select OK and type in the following: 
User ID: ingrid 
New Password: ingrid_2 
Confirm New Password: ingrid_2 
Then select Submit. 

The Successful Password Change window 
appears. 

  

5 Select OK. SLDCADA System News Screen is 
displayed. 

  

6 Select Labor>Time and Attendance from 
the SLDCADA Main Menu. 

The Time and Attendance Screen appears. 
 

  

7 Select the desired week ending date: 11-
12-00/11-18-00. 

The week ending date appears in the dialog 
box. 

  

8 Verify that the Employee Name is 
highlighted in the Search Criteria box, 
then enter the employee name (Ingrid 
Intermittent) into the Search Criteria 
Value box, then select Search. 

All of the Ingrid Intermittent is displayed in 
the Time and Attendance Data Screen. 
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Event # Action Expected Results  Observations  Requirements  
9 Enter the following information: 

JON: 123INTER 
P Shop: 02 
TYHR: RG  
 
Select Save. 

The validation screen is displayed. 
 
 

  

10 Close the validation screen. The Week 2 Time and Attendance screen is 
displayed. 

  

11 Select Time and Attendance Week 1 and 
enter the following: 
JON: 123INTER 
P Shop: 02 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

12 Close the validation screen. The Week 1 Time and Attendance screen is 
displayed. 

  

13 Select Time and Attendance Week 1 (11-
11-00) and change the hours to 8 for 
Thursday. Then sele ct the Time and 
Attendance Week 2 (11-18-00).    

A message is displayed asking if the user 
wants to save changes. 

  

14 Select OK. A message appears stating that the 
validation and save were successful. 

  

15 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

 INTERMITTENT BEGINS    
16 Enter in the following: 

TYHR: OS 
Then click on the Save icon. 

The following error message will be 
displayed: Intermittent employees cannot 
use ON, OS, or OU type hour codes. 
 
 

Failed 
 
TR #0012 

TYHR 
(Intermittent) 
(86) 
 
 

 



 

C-1 

Event # Action Expected Results  Observations  Requirements  
17 Close the validation message. The Time and Attendance Week 1 Screen is 

displayed. 
  

18 Enter in the following: 
TYHR: ON 
Then click on the Save icon. 

The following error message will be 
displayed: Intermittent employees cannot 
use ON, OS, or OU type hour codes. 
 
 

TR #0012  

19 Close the validation message. The Time and Attendance Week 1 Screen is 
displayed. 

  

20 Enter in the following: 
TYHR: OU 
Then click on the Save icon. 

The following error message will be 
displayed: Intermittent employees cannot 
use ON, OS, or OU type hour codes. 
 
 

TR #0012  

21 Close the validation message. The Time and Attendance Week 1 Screen is 
displayed. 

  

 INTERMITTENT ENDS    
22 Select the Add icon. A new row is added.   
23 Enter the following information: 

JON: 123INTER 
P Shop: 02 
TYHR: RG 
 
Select Save. 

The validation screen is displayed.   

24 Close the Validation screen. The Week 1 Time and Attendance Data 
Screen appears. 

  

25 Select MD next to the new row, then 
select Save. 

A message is displayed stating that you 
have marked records for deletion. 

  

26 Select OK. The record is deleted from the Time and 
Attendance window. 
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Event # Action Expected Results  Observations  Requirements  
27 Select Clocks Week 1 screen: 

Monday: 08:00-17:00 
Wednesday: 08:00- 17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
Note: This is where the employee will be 
able to enter in their hours for the days they 
work. 
 
 

TR #0005  

28 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

29 Enter in Clocks Week 2 Screen: 
Thursday: 09:00-17:00 
Friday: 09:00-17:00 
 
Then select the Save Icon. 

The hours are displayed. 
 
 

TR #0005   

30 Close the validation message. The Week 1 Time and Attendance Data 
Screen appears. 

  

31 Select the Work Schedule. The employees Time and Attendance Work 
Schedule Screen is displayed. 
 
 

TR #0004  

32 Select the Exit SLDCADA from the 
SLDCADA Main Menu. 

SLDCADA is exited and the user is 
returned to the Netscape browser. 

  

33 Select OK. The SLDCADA Login Screen is displayed.   
Criteria Evaluating Results: The only acceptable error would be the failure of the software to load properly or application failure due 
to core software dependencies. 
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SLDCADA Requirements List for Test Case CIVILIAN INTERMITTENT SA/AL 
 Req No Para No Title Requirement Pass/Fail TR # Priority 

 86 4.7.1.3 TYHR (Intermittent) Deny Intermittent employees the use of ON, OS or OU Type Hour  F SLDCADA-0012 3 
 Codes. 
 
 

 


